Forum Archive

Go Back   3D Realms Forums > 3D Realms Topics > Other Apogee/3D Realms Games > Shadow Warrior Source Code
Blogs FAQ Members List Social Groups Calendar Mark Forums Read

Notices

 
 
Thread Tools
Old 04-26-2009, 06:41 PM   #1
marked

marked's Avatar
SWP player movement problem
Every now and then when I enter a room, all of a sudden I'm grabbed and moved around like I'm on a conveyer belt or something. After a few seconds of moving and hitting the jump button I am released to normal movement. At first I thought that maybe I was riding on top of an enemy somehow but that is not the case. Has anyone else run into this? I forgot if I am running the latest build or the next one back.
marked is offline  
Old 04-27-2009, 03:13 AM   #2
ProAsm

ProAsm's Avatar
Re: SWP player movement problem
1. What level or map you playing.
2. Are you using the Hrp/Lrp
3. Go to exactly where this happens in the map then press 'T' and type in swloc - do that twice.
This will show you your framerate, position and what sector you in the map:
FPS:
Posx:
Posy:
Posz:
Angl:
Sect:

Post that information and I'll see if I can replicate the problem here.
__________________
http://www.proasm.com
ProAsm is offline  
Old 04-27-2009, 07:54 PM   #3
marked

marked's Avatar
Re: SWP player movement problem
It happens randomly and not in the same place every time. Today it happened as soon as I jumped out of the window at the beginning of the first level. I was dragged right up to the first enemy at the stairs. Another time was also in the beginning of the first level when I enter the room with the small pool in it.It has happened more than once in that room. I don't recall the other places because after it happens I just keep on playing.

Its a small problem, and if no one else has reported it don't spend time on it. Keep up the good work.

I'm running version 4.1.1 with the next to latest HRP.
marked is offline  
Old 04-27-2009, 08:15 PM   #4
Phayzon

Phayzon's Avatar
Re: SWP player movement problem
Try the latest version, at the moment that would be 4.1.4.
__________________
I made the first post on the VB!
"So I guess the news here is that not only is Australia the last to get anything new in regard to videogames, they're also the first to get them taken away." - LeadBullet
"We're part-time internet superheros." - Hudson
Phayzon is offline  
Old 04-27-2009, 09:01 PM   #5
marked

marked's Avatar
Re: SWP player movement problem
It happened again in the first level. This time I did not try to stop it and just let it run. What appears to be happening is the game is acting as though I have the move forward button pressed when it is not. When I do actually press the mouse button to move, it releases me back to normal. This does not happen in any other game so I'm assuming my mouse and drivers are functioning properly.

I'll check for a later version as suggested.
marked is offline  
Old 04-27-2009, 09:10 PM   #6
supergoofy

supergoofy's Avatar
Re: SWP player movement problem
delete swp.cfg and start the game with swpstartup. but before you start playing, configure with swpstartup the audio/video options.
supergoofy is offline  
Old 04-28-2009, 12:11 AM   #7
ProAsm

ProAsm's Avatar
Re: SWP player movement problem
Maybe also rebind your forward key somewhere else for a while just as a test, maybe you have a sticky key on your keyboard.
__________________
http://www.proasm.com
ProAsm is offline  
Old 04-29-2009, 06:51 AM   #8
hightreason

hightreason's Avatar
Re: SWP player movement problem
This has always happened in Build games, like if you had the key pressed and something interupted the game (Screensavers used to do it to me in Duke 3d when i didn't use the mouse) the game would not notice that i had let go of the key when i went back to it.

Also i have noticed that sometimes when a Build game is drawing a new area, the keys will sometimes lock like this if the drawing and the keypress/key release coincide at the right time.
__________________
High Treason
(My Website) (Second Site) (My YouTube)
Punk's not dead - and nor is Duke!
Ever get the feeling you are being ignored?
hightreason is offline  
Old 04-29-2009, 04:31 PM   #9
marked

marked's Avatar
Re: SWP player movement problem
You may be on to something there. It seems that when the problem happens, its when I jump out to an open area or as doors fly open and I'm entering a new room.
marked is offline  
Old 04-29-2009, 05:43 PM   #10
hightreason

hightreason's Avatar
Re: SWP player movement problem
Try playing without the HRP and see if it stops happening.
I imagine that it is happening in the time it takes to load the textures for the next area (ones you haven't seen in the level before that point)

When it happens, you just have to press the same keys or move the mouse the same way the player is going (Like if you are stuck going forward, press forward and it will stop when you let go of that key)

Like i said, it is just that the engine has not realised you let go of the key (if i remember rightly), so pressing it again and then letting go of it sorts it out.

Strangely (but completely unrelated), i work with MIDI files a lot, and it has a similar issue where it won't always notice that i let go of a note.
__________________
High Treason
(My Website) (Second Site) (My YouTube)
Punk's not dead - and nor is Duke!
Ever get the feeling you are being ignored?
Last edited by hightreason; 04-29-2009 at 05:47 PM.
hightreason is offline  
Old 05-01-2009, 03:49 AM   #11
IceColdDuke
Re: SWP player movement problem
ProASM are you compiling SWP in Visual Studio 2005 or 2008?
IceColdDuke is offline  
Old 05-01-2009, 11:39 AM   #12
TerminX

TerminX's Avatar
Re: SWP player movement problem
I thought he was using Watcom... hahaha.
TerminX is offline  
Old 05-01-2009, 11:40 AM   #13
IceColdDuke
Re: SWP player movement problem
Quote:
Originally Posted by TerminX View Post
I thought he was using Watcom... hahaha.
Haha I hope your kidding .
IceColdDuke is offline  
Old 05-01-2009, 11:44 AM   #14
TerminX

TerminX's Avatar
Re: SWP player movement problem
$ strings SWP.exe | grep -i watcom
Open Watcom C/C++32 Run-Time system. Portions Copyright (c) Sybase, Inc. 1988-2002.

Oh dear.
TerminX is offline  
Old 05-01-2009, 01:18 PM   #15
IceColdDuke
Re: SWP player movement problem
Quote:
Originally Posted by TerminX View Post
$ strings SWP.exe | grep -i watcom
Open Watcom C/C++32 Run-Time system. Portions Copyright (c) Sybase, Inc. 1988-2002.

Oh dear.
ProASM why the hell are you compiling this in Watcom?
IceColdDuke is offline  
Old 05-01-2009, 01:49 PM   #16
ProAsm

ProAsm's Avatar
Re: SWP player movement problem
Because I have always used watcom.
Back in my day (many moons ago) it was about the only thing around that was free and I just got used to it.
I have VS2005, maybe I try it sometime, buts its hard to break old habits.
Its like my Assembler work, I made my own assembler (Zodiac Assembler) with its own debugger back in the mid 80's when the 8086/8088 processors went 32 bit and I still use that same assembler to this day and it outsmarts most everything out there
I know, my son uses VS2008 etc and is always at me about my old fanshioned ways but.......
__________________
http://www.proasm.com
ProAsm is offline  
Old 05-01-2009, 02:47 PM   #17
IceColdDuke
Re: SWP player movement problem
Haha I was born in 1987 wasn't alive during that era , it doesnt matter anyway theres memory leaks when you compile it with Visual Studio 2008, which im trying to work out right now :|.
IceColdDuke is offline  
Old 05-01-2009, 03:51 PM   #18
ProAsm

ProAsm's Avatar
Re: SWP player movement problem
Memory leaks are everywhere and a bugger to eliminate.
Initially I used the Borland 5.1 compile and that worked great but it clashed horribly with several of my programs and Borland also take control of your path settings and I was forever fiddling with the thing so I dumped it.
Used M$ compiler for a while but ran into too many errors and warnings so I went back to the old faithfull watcom 1.5 I think it is.
Does the job, has a few problems but we live with it
__________________
http://www.proasm.com
ProAsm is offline  
Old 05-01-2009, 04:40 PM   #19
IceColdDuke
Re: SWP player movement problem
Quote:
Originally Posted by ProAsm View Post
Memory leaks are everywhere and a bugger to eliminate.
Initially I used the Borland 5.1 compile and that worked great but it clashed horribly with several of my programs and Borland also take control of your path settings and I was forever fiddling with the thing so I dumped it.
Used M$ compiler for a while but ran into too many errors and warnings so I went back to the old faithfull watcom 1.5 I think it is.
Does the job, has a few problems but we live with it
Well personally I like having a proper IDE, maybe im just spoiled .
IceColdDuke is offline  
Old 05-01-2009, 05:48 PM   #20
ProAsm

ProAsm's Avatar
Re: SWP player movement problem
From the assembler days, I never use an ide, I write the code in ultraedit or sometimes my own editor and then hit the make.bat file
__________________
http://www.proasm.com
ProAsm is offline  
Old 05-01-2009, 07:23 PM   #21
IceColdDuke
Re: SWP player movement problem
Quote:
Originally Posted by ProAsm View Post
From the assembler days, I never use an ide, I write the code in ultraedit or sometimes my own editor and then hit the make.bat file
Im trying to get it ported over to Visual Studio 2008, but again theres a huge memory leak, and its really hacky having to compile with /Mt :|. I know how to read assembly(meaning I just can look at it and know what it does, but understanding the low level mechanics of build...wouldn't even know were to start : )).
IceColdDuke is offline  
 

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:40 PM.

Page generated in 0.12998390 seconds (100.00% PHP - 0% MySQL) with 18 queries

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

Website is 1987-2014 Apogee Software, Ltd.
Ideas and messages posted here become property of Apogee Software Ltd.