Forum Archive

Go Back   3D Realms Forums > 3D Realms Topics > Other Apogee/3D Realms Games > Shadow Warrior Source Code
Blogs FAQ Members List Social Groups Calendar Mark Forums Read

Notices

 
 
Thread Tools
Old 12-05-2012, 09:37 AM   #1
Litude

Litude's Avatar
Sound crash after compiling SW from source code
Hey,

I'm having a little trouble with my executable that I've compiled from the Shadow Warrior source code. I've downloaded the source code from here and took some modified .H files from here by jbailey to make the code compile under Open Watcom 1.6. I've made no other changes whatsoever.

Now while the code compiles fine and the game itself also starts fine, it occasionally crashes when certain sound effects are supposed to be played with the following error message:
Code:
Assertion failed: num >= 0 && num < DIGI_MAX
 SOUNDS.C, line 739
One example of a situation when this happens is in Wanton Destruction when trying to shoot the bunnies in the level Monastery using the Riot Gun.

Does anyone know how one could tweak the source code to fix this problem?
Litude is offline  
 

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:39 AM.

Page generated in 0.08160996 seconds (100.00% PHP - 0% MySQL) with 18 queries

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

Website is 1987-2014 Apogee Software, Ltd.
Ideas and messages posted here become property of Apogee Software Ltd.