Forum Archive

Go Back   3D Realms Forums > 3D Realms Topics > Other Apogee/3D Realms Games > Shadow Warrior Source Code
Blogs FAQ Members List Social Groups Calendar Mark Forums Read

Notices

 
 
Thread Tools
Old 07-02-2007, 12:31 PM   #81
ProAsm

ProAsm's Avatar
Re: Swp updated.
@ skitey - regarding the looping.
Yes this seem an original problem by the makers of SW.
Found this in the code:
Code:
Known remaining issues:
- Audio stuttering.
- CD Audio not looping properly (currently hard coded to restart about every 200 seconds.
Check and see if it restarts after 200 seconds.
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-02-2007, 01:53 PM   #82
0815Jack
Re: Swp updated.
@ ProAsm: i have still problems with CD music .... if i load savegames from different levels the music doesnt change....

and if i start new games AFTER loading savegames the music still stays the same.....

any idea?
0815Jack is offline  
Old 07-02-2007, 01:59 PM   #83
Hendricks266

Hendricks266's Avatar
Re: Swp updated.
BTW, ProAsm, could you release the source to SWP once v3.8 final comes out? Your page still only has the v2.3 source code.
Hendricks266 is offline  
Old 07-02-2007, 02:02 PM   #84
skitey

skitey's Avatar
Re: Swp updated.
Quote:
Originally Posted by ProAsm View Post
@ skitey - regarding the looping.
Yes this seem an original problem by the makers of SW.
Found this in the code:
Code:
Known remaining issues:
- Audio stuttering.
- CD Audio not looping properly (currently hard coded to restart about every 200 seconds.
Check and see if it restarts after 200 seconds.
Testing CD-Music Loop @ Episode 1 Level 1 (Dojo)

Results:
music DON'T restart after 200 seconds!
After 7 Minutes it still don't loop (damn silence).
...
after this test i pressed [ESC],
-> Options
-> Sound Menu
and the music started again to play

...so far my bug-reporting
skitey is offline  
Old 07-02-2007, 02:27 PM   #85
ProAsm

ProAsm's Avatar
Re: Swp updated.
Quote:
Originally Posted by Hendricks266 View Post
BTW, ProAsm, could you release the source to SWP once v3.8 final comes out? Your page still only has the v2.3 source code.
Yeah sure np, its just that up until recently the changes were so slight that I did not bother, but yeah once we have a solid 3.8 I will.

Btw, the problem with the CDDevice not working if its CDDevice=0 is a Swp fault and not a country fault as I first thought so I have fixed that now.
The Voxels problem was not even connected, must have slipped past me.

The ReverseStereo was somehow connected to the Y-Invert (mouse), anyway thats fixed now also.

The music not looping has me beat as it does give the 'loop' command everytime it starts up.
There is a problem though that I noticed in the code is that in many many places it relys on a 'cdvalid' flag and that flag is always 0 regardless of what the cd is doing, so tracing through the code I see the actual CDPlay detection does not seem to be working where one monitors whether the CD track has ended, the CD has been rejected etc, so this is probably the reason for many problems also, so thats gonna need serious attention also.

Hendricks266, in your case with your Virtual drive, if you for instance set a drive, regardless of the letter but one that makes your Music work, does it stay there on that letter when running SwpStartup the next time ?
Quote:
3. A lot of options seem to be reset to the defaut whenever SwpStartup is opened. Among these is Resolution, HRP ZipLoader, CDDevice, and possibly others.
This I cannot get to happen here.
Can you give me more detail on how to get it to happen.
BUT... if you have no Swp.cfg file at all, ie you deleted it, it will load the original defaults, not the saved ones in the SwpStartup.cfg but the ones that the software was programmed for.
This has changed now, in that if you have deleted your Swp.cfg and you do have saved defaults in your SwpStartup.cfg it will now use those.
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-02-2007, 02:53 PM   #86
Hendricks266

Hendricks266's Avatar
Re: Swp updated.
Quote:
Originally Posted by ProAsm View Post
Hendricks266, in your case with your Virtual drive, if you for instance set a drive, regardless of the letter but one that makes your Music work, does it stay there on that letter when running SwpStartup the next time ?

This I cannot get to happen here.
Can you give me more detail on how to get it to happen.
BUT... if you have no Swp.cfg file at all, ie you deleted it, it will load the original defaults, not the saved ones in the SwpStartup.cfg but the ones that the software was programmed for.
This has changed now, in that if you have deleted your Swp.cfg and you do have saved defaults in your SwpStartup.cfg it will now use those.
1. No matter what I set it to, the selection box is always set back to D: whenever I open SwpStartup.exe. The same thing happens with the list I provided earlier. Perhaps it is something in my configuration files. In either case, tinkering with the numbers should fix the CD music thing, it's just that whenever I open SwpStartup it will be reset.

EDIT: I just found out that I was not using the “Save Defaults” option.

2. In case you need to know, I do have one USB memory key plugged in; I have set as drive J:.

3. Could you add a third “episode” to the selection menu, which would be a user map selection menu? You could just copy the code from JFDuke3D\EDuke32\Duke3DW, as that feature is in those ports. Also, in regards to user maps, once you select one with the command line parameters, selecting an episode in the New Game box will just start the user map over again.

4. Would it be possible to add some new things to swcustom.txt? The main theme, intermission screen, boss theme, and ending theme MIDIs/SFX/CD tracks cannot be changed, so could you put in something like this:

Code:
theme 1 // Main Theme (Okinoww!a)
{
    song     "THEME.MID"
    cdatrack 2
}

theme 2 // Intermission Screen Theme (Okinoww!a - Reprise)
{
    song     "ENDLEV3.VOC"
    cdatrack 3
}

theme 3 // Boss Theme (Shadow Raver)
{
    song     "BOSS.MID" // Does Not Exist
    cdatrack 13
}

theme 4 // Ending Theme (Lo Wang's Rap)
{
    song     "ENDING.MID" // Does Not Exist
    cdatrack 14
}
5. Are you planning of making SWPBuild? JonoF most likely has added and fixed things since the 20051009 version. Plus, there is at least one bug that needs attention: it is impossible to access any tags using the “3” button, as it does not recognize it, but instead it provides a preview mode for ROR situations. The preview function should me moved to another key so accessing tags with that key will work.

6. Whew, that was a long post!
Last edited by Hendricks266; 07-02-2007 at 03:08 PM.
Hendricks266 is offline  
Old 07-02-2007, 03:37 PM   #87
ProAsm

ProAsm's Avatar
Re: Swp updated.
Quote:
EDIT: I just found out that I was not using the “Save Defaults” option.

2. In case you need to know, I do have one USB memory key plugged in; I have set as drive J:.
Does this mean the cddevice is working or you still have the problem.
If you still have the problem could you zip and mail me this image file and explain how I can set it up here on a vitual drive.
You can mail it to: info at proasm dot com

Regarding the 3rd episode for User maps or stuff.... hehe, I have tried, boy oh boy I have tried.
When they made Duke3d they they made it on Mars, and Shadow Warrior was made on Venus and these 2 teams never spoke a word to each other.
Thats about as close you going to get to any compatibility between the 2
I'm quite amazed they both share the build engine.
Anyways yes we need a third episode and will get there sometime.

Regarding the expanding of the SwCustom file, yes I have thought a lot about this and will go there as well especially now with more stuff working than before.

Regarding the Build.exe itself, JonoF has made some progress here although I have not checked how much.
I see it now runs many screen resolutions and maybe even fullscreen and I've used it a bit and never had a crash which was common before.
I'll make some comparisons or compile a new one and let you check it out.
Other than that, currently I cannot remember any commands in Build, hell just to figure out the ST1 sprite for my TV Monitor 'hack' took me forever
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-02-2007, 04:22 PM   #88
Hendricks266

Hendricks266's Avatar
Re: Swp updated.
Quote:
Originally Posted by ProAsm View Post
Does this mean the cddevice is working or you still have the problem.
If you still have the problem could you zip and mail me this image file and explain how I can set it up here on a vitual drive.
You can mail it to: info at proasm dot com
I haven't tried it yet.

For the image thing:
A) It's HUGE (450+ MB).
B) I have dial-up.
C) You can make one yourself from your SW CD.

I'll explain it now.

Open up your CD burning software and select “Make CD Image”. Have it make an image of your SW CD. Make sure that it is an exact copy of the CD, having 14 tracks (1 data track + 13 music tracks), and save it as a .CUE+.ISO.

Download the attachment, and do what the readme says to do. After opening the VCDROM.sys file, mount a drive, and load your image. Then use SWPStartup to set it to the drive letter of the new virtual drive, and you now have CD music, minus the CD.
Attached Files
File Type: rar winxpvirtualcdcontrolpanel.rar (14.3 KB, 2 views)
Hendricks266 is offline  
Old 07-02-2007, 04:42 PM   #89
supergoofy

supergoofy's Avatar
Re: Swp updated.
ISO format doesn't support Audio or Mixed Mode CDs.

You mean Bin+Cue (CDRWin Image - CDRWin was the application that introduced this image format) or Nrg (Nero Image format) or mdf+mds (Alcohol Image format) or ccd+img+sub(+cue sometimes) (CloneCD Image format) etc. etc.

Nero Burning ROM and Daemon Tools are easy to handle.

Download the free version of Daemon Tools 4.09.1 from:
http://www.disc-tools.com/download/daemon
During installation uncheck the addware (Searchbar and Save Now), I don't remember the exact name, but it must be 2nd or 3rd in the list of files to be installed.

I also recommend you to download and install SPTD v1.50 (needed by Daemon Tools) from:
http://www.disc-tools.com/download/sptd

A trial version of Nero Burning ROM can be downloaded from:
http://www.nero.com

Most burners come with an OEM (full working) copy of Nero.
Last edited by supergoofy; 07-03-2007 at 11:56 AM.
supergoofy is offline  
Old 07-02-2007, 05:51 PM   #90
Hendricks266

Hendricks266's Avatar
Re: Swp updated.
Oops. I use ccd+img+sub+cue, and I forgot.

I guess that the tool I uploaded is pretty useless, then.

Actually, I use MagicDisc for my SW virtual drive. I mixed up the two.
Hendricks266 is offline  
Old 07-03-2007, 02:30 PM   #91
ProAsm

ProAsm's Avatar
Re: Swp updated.
Ok that all worked great and the image is 584 MB...
Just as well you did not email it
Its sees it as my G drive (drive 1 in SwpStartup) as my CDRom is F and it works great.
Well thats another CD I can pack away which is more than what I can so for my poor Duke3d Atomic CD as thats pretty useless these days
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-05-2007, 09:30 AM   #92
ProAsm

ProAsm's Avatar
Re: Swp updated.
Regarding the installation the Daemon Tools, just make sure you dont have any memory sticks or anything in your PC as it does not have the intelligence to know you have removed the memory stick.
This caught me out today at work as I took the app and image to work on my memory stick and of course it was plugged in to install it.
When all was up and running my CDRom was D, my stick was E and the Image was F which is correct and worked well.
But... then I removed the memory stick and still Daemon said my Image was in F which now was wrong as Windows says its in E which is what SW requires, so SW did not work.
I then rebooted to see but still Daemon insisted the the Image was in F which was wrong, it was in E according to Windows and SW depends on what Windows says.
No matter what I did it would not work so to enable SW to play I had to plug in my memory stick which sucks.
The only way I could get it to work without the stick, was tell Daemon to make 2 virtual drives which the 2nd one it now made as E so I put the image in there as well so I end up with 2 Virtual drives both with the same image just to get SW to work properly in case I add/remove my memory stick
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-05-2007, 04:07 PM   #93
ProAsm

ProAsm's Avatar
Re: Swp updated.
Quote:
theme 2 // Intermission Screen Theme (Okinoww!a - Reprise)
{
song "ENDLEV3.VOC"
cdatrack 3
}
This one is a problem because it is a VOC file and the chances of anyone changing it with another VOC file is small.
Any suggestions ?
The rest is working great including all the cdatrack= in the custom file.
Anyone want to make a default BOSS.MID and/or ENDING.MID
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-05-2007, 09:55 PM   #94
Hendricks266

Hendricks266's Avatar
Re: Swp updated.
But you can do it, right? .WAV files work as well. You could also make it possible for someone to put a MIDI in there as well.
Hendricks266 is offline  
Old 07-06-2007, 01:54 AM   #95
ProAsm

ProAsm's Avatar
Re: Swp updated.
Ok thats all I wanted to know, whether to leave it in or take it out.
Ok i'll make it so it looks to see if its a .mid and if not treat it as a voc/wav
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-06-2007, 02:23 AM   #96
Martin Howe

Martin Howe's Avatar
Re: Swp updated.
Quote:
Originally Posted by ProAsm View Post
This one is a problem because it is a VOC file
The same applies in DN3D, too, though. I remember reading an interview with Lee Jackson where he said that 3DR explicitly specified that they wanted a sound, rather than music, file to be played; but I can't remember why
Martin Howe is offline  
Old 07-06-2007, 07:56 PM   #97
Hendricks266

Hendricks266's Avatar
Re: Swp updated.
You can't have more than one MIDI playing at once. Hence the music had to be ambient sounds, which work better anyway.
Hendricks266 is offline  
Old 07-07-2007, 12:43 AM   #98
ProAsm

ProAsm's Avatar
Re: Swp updated.
Quote:
Originally Posted by Hendricks266 View Post
But you can do it, right? .WAV files work as well. You could also make it possible for someone to put a MIDI in there as well.
BUT you cannot have a WAV as that does not exist in SW as far as I can see, only in Duke.
Anyone ever got a WAV to work in SW ?
__________________
http://www.proasm.com
Last edited by ProAsm; 07-07-2007 at 01:04 AM.
ProAsm is offline  
Old 07-07-2007, 08:38 AM   #99
ProAsm

ProAsm's Avatar
Re: Swp updated.
Swp update Version 3.8.5

CD Music
The main and possible only changes here is the variation of the cdatrack in the SwCustom.txt file now all function.
These track numbers are in the order of 2 to 14.

Music
All the Songs now function correctly for each level.

Themes
An addition 4 theme headings have been added to the end of the SwCustom.txt file and it is now possible to change the said theme.

Please Note: In all cases ONLY MIDI music is accepted except for the (theme 2) which will also accept a MID otherwise will default to its ENDLEV3.VOC

Known bugs:
The music will not loop for whatever reason - working on it.

A new SwCustom.txt.sample is added as the cdtrack numbers are now correct with the game and includes the additional theme's.

http://www.proasm.com/files/sw/Swp38_5.zip

Some fixes and added Reverse Stereo option.
http://www.proasm.com/files/sw/SwpStartup.zip

Lotsa testing needed to see if all the track/levels works ok + the midi music.

The latest code build.exe for anyone who wants to check it out.
http://www.proasm.com/files/sw/swbuild.zip
__________________
http://www.proasm.com
Last edited by ProAsm; 07-07-2007 at 08:45 AM.
ProAsm is offline  
Old 07-07-2007, 01:33 PM   #100
ProAsm

ProAsm's Avatar
Re: Swp updated.
Quote:
Originally Posted by Another Duke Fan
BTW, I have a real headache with the new Swp update Version 3.8.5. I am not able to exit the game, nor the arrow keys work on the menu, once killed inside the game. Please, check that.
Just transfered the query as I dont want to interfere in the other topic
Please delete your Swp.cfg and run either SwpSetup or SwpStartup as I do not have any problems like that here at all.
I have checked several times now and all is well.
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-07-2007, 01:44 PM   #101
supergoofy

supergoofy's Avatar
Re: Swp updated.
Swp v3.8.5 is working just fine for me.
supergoofy is offline  
Old 07-07-2007, 03:48 PM   #102
Another Duke Fan

Another Duke Fan's Avatar
Re: Swp updated.
Quote:
Originally Posted by ProAsm View Post
Just transfered the query as I dont want to interfere in the other topic
Please delete your Swp.cfg and run either SwpSetup or SwpStartup as I do not have any problems like that here at all.
I have checked several times now and all is well.
Thank you very much ProAsm! That did it. All works just fine now.
__________________
アーティスト
Another Duke Fan is offline  
Old 07-07-2007, 04:35 PM   #103
supergoofy

supergoofy's Avatar
Re: Swp updated.
Another Duke Fan I can send you my Swp.cfg. I have assigned the keys like in EDuke32 : space=jump , left ctrl=crouch , E=open/use , Q=fire
This way is better if you use mouse + keyboard. For me it is easier to play with keyboard + mouse.

i have also disabled hrploader (=0), I load it manually.
supergoofy is offline  
Old 07-07-2007, 04:48 PM   #104
Another Duke Fan

Another Duke Fan's Avatar
Re: Swp updated.
No, thanks. It is all working just fine again. I am playing dominantly with the mouse only: 1 x left = fire; 2 x left = fire; 1 x right = walk forwards; 2 x right = jump; 1 x middle = open; 2 x middle = crouch; 1 x thumb = inventory; 2 x thumb = map. I am really happy with this configuration and won`t change it.
__________________
アーティスト
Another Duke Fan is offline  
Old 07-08-2007, 03:12 AM   #105
ProAsm

ProAsm's Avatar
Re: Swp updated.
Glad you got sorted out there Another Duke Fan.
This happens sometimes when an additional option is added, ReverseStereo in this case, and the player has a somewhat indifferent key setup.

It would really be interesting to see what everyone uses as their Key / Mouse setup.
This would help a lot towards defining a 'Default' setup for Swp.
I did a small survey on a local forum several months ago and for single play thats how Swp is defaulted atm.
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-08-2007, 09:36 AM   #106
Another Duke Fan

Another Duke Fan's Avatar
Re: Swp updated.
Well, I am mainly using mouse with 4 buttons covered with double functions, e.g. for single and double click. I found this, combined with the mouse view, to be the most comfortable configuration for me. I am using the keyboard too, but only occasionally and mostly to exit / enter the game.
__________________
アーティスト
Another Duke Fan is offline  
Old 07-08-2007, 09:45 AM   #107
skitey

skitey's Avatar
Re: Swp updated.
Quote:
Originally Posted by ProAsm View Post
Glad you got sorted out there Another Duke Fan.
This happens sometimes when an additional option is added, ReverseStereo in this case, and the player has a somewhat indifferent key setup.

It would really be interesting to see what everyone uses as their Key / Mouse setup.
This would help a lot towards defining a 'Default' setup for Swp.
I did a small survey on a local forum several months ago and for single play thats how Swp is defaulted atm.
hehe, you asked and i surely answer ^_- :

Using Mouse+Keyb, settings are always the same as every other fps...
(only the main buttons)

Mouse (surely mouseaim enabled ):
LeftButton - Fire
RightButton - Run
Middle - Alt_Fire
Wheel Up - Next Weapon
Wheel Down - Prev. Weapon

Keyboard:
Arrow Up - Forward
Arrow Down - Back
Arrow Left - Slide Left
Arrow Right - Slide Right
Shift Right - Jump
Ctrl Right - Crouch
Enter - Use
Inventory left/right - Keys left from Backspace
Use Inventory - Backspace

Reload - Numpad 0 .....argh,damn SW doesnt need to reload
Last edited by skitey; 07-08-2007 at 09:48 AM.
skitey is offline  
Old 07-08-2007, 11:14 AM   #108
Mr.Fibbles

Mr.Fibbles's Avatar
Re: Swp updated.
I use AWSD to move around with mouse view.
SPACE is probably my preference for jump while either CTRL or C as duck.
use is usually E but if there is a lean it ends up being F.
RIGHTButton is usually the alt-fire
LEFTButton is fire
scroll wheel is change weapons
SHIFT is walk/run (depending on the game and whether or not autorun is enabled)

I like to keep things consistent but I can adapt.
__________________
http://thaunandshad.com
Mr.Fibbles is offline  
Old 07-09-2007, 06:12 AM   #109
supergoofy

supergoofy's Avatar
Re: Swp updated.
Mr.Fibbles I use almost the same keyb + mouse combo
Last edited by supergoofy; 07-09-2007 at 06:30 AM.
supergoofy is offline  
Old 07-14-2007, 09:26 AM   #110
ProAsm

ProAsm's Avatar
Re: Swp updated.
Swp update Version 3.8.6

Well this I think will be the last of this series and if there are no gripes I'll convert it to a release etc.

Basically all music and CD music should now loop ok.
Made the startup screen a little bigger (10%) to accomodate PlayWang etc.

http://www.proasm.com/files/sw/Swp38_6.zip - includes all files.
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-14-2007, 02:03 PM   #111
Hendricks266

Hendricks266's Avatar
Re: Swp updated.
I have something to report. I changed the swcustom.txt of Lo Nukem to have this: (also putting the levels in correct order and utilizing the five Duke MIDIs)

Code:
theme 2
{
     song "BONUS.VOC"
}
And when I put this in there, the normal intermission music plays, and the SWP.log says something to the effect of “BONUS.VOC failed to initalize”.

Then I tried this:

Code:
theme 2
{
     song "GRABBAG.MID"
}
And at the intermission screen, the game slowed to ~0-3 FPS. No music played at all. The log had many, many instances in a row of “GRABBAG.MID failed to initalize”.

I have not tried the cdatrack value yet for theme 2.
Hendricks266 is offline  
Old 07-14-2007, 03:17 PM   #112
ProAsm

ProAsm's Avatar
Re: Swp updated.
Good heavens, I've tried that GRABBAG.MID many times and actually used it as my test song.
The Bonus.voc is correct, that one either plays a .mid or the original ENDLEV3.VOC
The way SW plays vocs and wavs is very wierd and they need to be defined before the game starts so I did not persue the matter too much.
Thanks for the report, I'll test at out asap as maybe something has gone wrong somewhere.
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-14-2007, 03:25 PM   #113
Hendricks266

Hendricks266's Avatar
Re: Swp updated.
EDuke32 uses a fancy dynamic-to-static system so you can redefine tile numbers if you add a parameter to the CON files. Perhaps you can make something like it, but just for the one sound (ENDLEV3.VOC) and have it substitute in whatever is specified in SWCustom.txt if it is a .voc/.wav.
Hendricks266 is offline  
Old 07-14-2007, 03:36 PM   #114
ProAsm

ProAsm's Avatar
Re: Swp updated.
Yeah I tried something like.
I created 2 extra .voc defines at the end in digi.h and used those 2 to set the .voc filenames for either a theme or a level, then load them at InitGame but it failed.
The code for a wav or voc seems to be intact but I cannot get it going and felt for a voc its not important and decided to concentrate on a .mid
Btw, doing some tests here I get exactly what you get - seems strange as in a level it works fine and they use the same routine to start the mid.
__________________
http://www.proasm.com
Last edited by ProAsm; 07-14-2007 at 03:40 PM.
ProAsm is offline  
Old 07-15-2007, 04:47 AM   #115
0815Jack
Re: Swp updated.
i have still the problem that if i load savegames the corresponding music from the cd isnt played.....

is this intended or still a bug?
0815Jack is offline  
Old 07-15-2007, 07:22 AM   #116
Valherran
Re: Swp updated.
Hi guys i have a request i would like to make, for the many years spent playing this game, and the recent months i have discovered this high-res pack, can you please, Please, PLEASE, remake the vehicles and controllable objects in the game. They are so blocky and 1/2 assed looking i cant bare look at them, the CARS looked better than those did. Could you do it?
Valherran is offline  
Old 07-15-2007, 07:59 AM   #117
Roma Loom

Roma Loom's Avatar
Re: Swp updated.
Impossible. The vehicles are actually raised sectors of the ground and cannot be raplaced by models.
__________________
GRPViewer, DN3D/SW Models
Roma Loom is offline  
Old 07-15-2007, 08:14 AM   #118
Hendricks266

Hendricks266's Avatar
Re: Swp updated.
There could be a hackish way to do it, which could also be used for the statue of Abraham Lincoln in DukeDC level 2. What you do is make all of the sectors blend in with the floor (not erasing them), and add a new sprite at a certain tilenum with a sprite that you can define a model to. Of course, it wouldn't be perfect, but it's the only way. Don't get your hopes up, though.
Hendricks266 is offline  
Old 07-15-2007, 09:39 AM   #119
ProAsm

ProAsm's Avatar
Re: Swp updated.
Quote:
Originally Posted by 0815Jack View Post
i have still the problem that if i load savegames the corresponding music from the cd isnt played.....

is this intended or still a bug?
Currently the type of music played with the game is not saved but we'll look into that.
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-15-2007, 10:03 AM   #120
heebijeebi
Re: Swp updated.
all the non-shareware-levels have the same music when I play with the last swp version....
__________________
SW HRP 07-03-07
heebijeebi is offline  
 

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:03 PM.

Page generated in 0.19530797 seconds (100.00% PHP - 0% MySQL) with 17 queries

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

Website is ©1987-2014 Apogee Software, Ltd.
Ideas and messages posted here become property of Apogee Software Ltd.