Forum Archive

Go Back   3D Realms Forums > 3D Realms Topics > Other Apogee/3D Realms Games > Shadow Warrior Source Code
Blogs FAQ Members List Social Groups Calendar Mark Forums Read

Notices

 
 
Thread Tools
Old 04-18-2009, 11:09 AM   #1
KPL
SWP mouse issue
I have the latest SWP port installed with the sw_hrp. if i look up or down too fast there is some sorta mouse lag. It's bad enough that it make the game unplayable. Any ideas how to fix this?
KPL is offline  
Old 04-18-2009, 11:25 AM   #2
supergoofy

supergoofy's Avatar
Re: SWP mouse issue
what do you mean? I haven't encountered any problems with Swp 4.1.3

only SwpStartup 2.7 has 1 or 2 minor bugs (I think): trilinear filtering is reset to bilinear when you first start Swp (swp.cfg doesn't exist before first start). But I haven't confirm it second time, so maybe it was something wrong from my end. Plus something else that I cannot remember.
supergoofy is offline  
Old 04-18-2009, 03:08 PM   #3
ProAsm

ProAsm's Avatar
Re: SWP mouse issue
Quote:
Originally Posted by KPL View Post
I have the latest SWP port installed with the sw_hrp. if i look up or down too fast there is some sorta mouse lag. It's bad enough that it make the game unplayable. Any ideas how to fix this?
I also noticed this recently and in my case it turned out to be a FlashVideo Converter that I had installed together with an FLV Player.
As soon as I uninstalled these 2 items the lag dissapeared.
When I have some time I'll look into it and see why it does this.

** Edit **
Strange, I've just gone an re-installed the suspected FLV, DivX and other files but it had no effect on the mouse smoothness.
I even tried a reboot but my mouse is as smooth as any other game.
Others have been in the same boat as you and its some application that clashes with SWP.
On another forum as soon as the guy re-installed Windows Xp he never had the problem again.
So unless I can have the problem actually happening on my PC, there is no way I can make a fix for it
What you can try is go into the 'Game Options' menu and set 'Auto Save Game' to 'OFF' and see what happens.
__________________
http://www.proasm.com
Last edited by ProAsm; 04-18-2009 at 04:14 PM.
ProAsm is offline  
Old 04-18-2009, 05:05 PM   #4
KPL
Re: SWP mouse issue
Hmm now that I think of it. I did start playing Qaukelive the other week. I think it updates the flash plugin since the game runs from a browser window. Also, I had to download firefox to play Qaukelive becuase it wants the latest version of IE and i have ver.6 I had SWP awhile back and it was working fine. I only recently reinstalled it to play it on Yang and thats when i noticed the mouse problem. In my add remove progams I see Adobe flash player 10 activeX and Adobe flash player 10 plugin. What version of these do you have if any? and do you think I can uninstall them and still be able to play flash video on websites?
KPL is offline  
Old 04-19-2009, 02:48 PM   #5
ProAsm

ProAsm's Avatar
Re: SWP mouse issue
Quote:
Adobe flash player 10 activeX and Adobe flash player 10 plugin
I currently have both of those installed as well as: Flash Video Converter 1.0.1 and FLV Player 2.0.
I have a note written on my pad here that says "Do not install Movavi Flash Convert as it creates problems" as i know I had that installed also and removed it for some reason, maybe this is it and I'm not going to install it again to test as I would not write such a note if it was not something serious.
Yesterday I also installed the Firefox addon "Flash Video Downloader 1.9.1" and I still dont have any mouse problems.
BTW this downloader works better than all the others I've tried and is so easy to activate
__________________
http://www.proasm.com
ProAsm is offline  
Old 04-28-2009, 11:58 AM   #6
Arch-Valentine
Re: SWP mouse issue
I have that same problem using SWP. Makes using the mouse quite frustrating.
Arch-Valentine is offline  
Old 04-28-2009, 01:20 PM   #7
ProAsm

ProAsm's Avatar
Re: SWP mouse issue
It would be interesting to know which app is causing it as I guarentee you if you installed SWP on a new PC you wont have any mouse problems.
I have 4 PC's here which I have to my disposal to test things on and in all cases I cannot get this mouse slugishness to happen again.
__________________
http://www.proasm.com
ProAsm is offline  
Old 04-28-2009, 03:14 PM   #8
Arch-Valentine
Re: SWP mouse issue
Yeah it would be nice to see what is conflicting with it. Formatting seems a tad bit extreme just to see it work properly. As for some of the things that's been discussed, I have Vista/Flash 10 and have played Quake Live on this computer. Dunno if any of that is apart of the problem or not, just saying.
Arch-Valentine is offline  
Old 04-28-2009, 04:08 PM   #9
ProAsm

ProAsm's Avatar
Re: SWP mouse issue
It has something to do with a flash player as I installed several flash related apps including Quake Live all around the same time.
I have since un-installed almost all of them, but even re-installing I cannot get the problem back.
__________________
http://www.proasm.com
ProAsm is offline  
 

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:01 PM.

Page generated in 0.10317492 seconds (100.00% PHP - 0% MySQL) with 16 queries

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

Website is 1987-2014 Apogee Software, Ltd.
Ideas and messages posted here become property of Apogee Software Ltd.