Forum Archive

Go Back   3D Realms Forums > 3D Realms Topics > Other Apogee/3D Realms Games > Rise of the Triad (1995) Source Code
Blogs FAQ Members List Social Groups Calendar Mark Forums Read

Notices

 
 
Thread Tools
Old 12-25-2002, 01:03 PM   #1
jbailey

jbailey's Avatar
sound problems
After a bit of work, I got music playing, but sound
effects are still not working properly. My environment is windows xp pro running the latest version of soundfx emulator (2.02 I think).
I have also tried vdms, no change. Here's the current status:

The original version of rott.exe runs perfectly, sound effects and music.

the setup program (sndsetup.exe) and my compiled version of the rott.exe both exhibit the same behavior. either there are no sound effects or sometimes the sound effects will loop. As far as
I can tell, even the ported code (linux, mac, win32) currently also have this problem, I have tried setting interrupts, address, etc, in my emulator, but nothing seems to make any difference, both my executable and sndsetup.exe lock up when ever I try to get sound effects running. At this point I'm glad I have at least music playing. Please note that before I can run any of my compiled programs, I have to patch the exe with cli2nop or it locks completly. Any ideas?

Thanks!
jbailey
__________________
Download Winrott here:

http://www.riseofthetriad.dk/DL_GlROTT.htm

jbailey
jbailey is offline  
Old 12-25-2002, 02:51 PM   #2
The Stinger
Guest
Re: sound problems
Yeah I downloaded the test version of the rott win32 port and the sounds works in sndsetup but not in the windows version of rott.exe. It works perfectly in the dos version though.

Btw I've got a soundblaster live... dunno if it has something to do with that?
 
Old 12-25-2002, 06:14 PM   #3
IceColdDuke
Re: sound problems
In win32 rott, the old sound setup is obsolete [img]images/icons/smile.gif[/img] , they use DirectSound now.
IceColdDuke is offline  
 

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:27 AM.

Page generated in 0.13999391 seconds (100.00% PHP - 0% MySQL) with 16 queries

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

Website is 1987-2014 Apogee Software, Ltd.
Ideas and messages posted here become property of Apogee Software Ltd.