Forum Archive

Go Back   3D Realms Forums > 3D Realms Topics > Other Apogee/3D Realms Games > Shadow Warrior Source Code
Blogs FAQ Members List Social Groups Calendar Mark Forums Read

Notices

 
 
Thread Tools
Old 06-24-2007, 12:50 PM   #41
Wellenreiter

Wellenreiter's Avatar
Re: Swp updated.
Quote:
Originally Posted by skitey View Post
nah, actually it DON'T work.
sw.cfg has only playcd entry, creating cddevice entry doesnt work at all.
same result as if i change the swp.cfg => no cd music at all ^_-
No idea what's wrong there, but it works for me. It really was Swp.cfg though. Maybe deleting sw.cfg helps?
Wellenreiter is offline  
Old 06-24-2007, 01:05 PM   #42
ProAsm

ProAsm's Avatar
Re: Swp updated.
Quote:
yeah I reinstalled my whole computer today and now it works just fine ... strange!
Thats good to hear and a bit of a relief this end.
Its amazing what a good re-install can do - does wonders sometimes
__________________
http://www.proasm.com
ProAsm is offline  
Old 06-24-2007, 10:59 PM   #43
Dennis J
Re: Swp updated.
I seemingly can't succeed in enableing CD music (or MIDI, either!). MAP01's viewscreen is still glichy.
Dennis J is offline  
Old 06-25-2007, 07:45 AM   #44
skitey

skitey's Avatar
Re: Swp updated.
nah, midi works like a charm!
check your sound-settings, maybe your MIDI volume changed (happens to me, if i play midis outside of the game)
skitey is offline  
Old 06-25-2007, 09:19 AM   #45
ProAsm

ProAsm's Avatar
Re: Swp updated.
Quote:
MAP01's viewscreen is still glichy.
Never knew it was glichy in the first place - mine looks just great.
Show us a pic.
__________________
http://www.proasm.com
ProAsm is offline  
Old 06-27-2007, 06:32 AM   #46
WarHammer

WarHammer's Avatar
Re: Swp updated.
I'm sure he means the viewscreen for the remote control car with the silver key, which hasn't worked since day one.
You either have to use cheat codes or blindly fumble with the controls in hopes that you get lucky to get the key.
WarHammer is offline  
Old 06-27-2007, 09:24 AM   #47
ProAsm

ProAsm's Avatar
Re: Swp updated.
Ahhh yes ok.
Yes, the best way currently around that problem is to switch to 8 bit BPP and once past that go back to 32
__________________
http://www.proasm.com
ProAsm is offline  
Old 06-27-2007, 10:48 AM   #48
Psykomanius

Psykomanius's Avatar
Re: Swp updated.
But, ProAsm you can fix it. Right
You are a Code Guru.....
Hehe...
__________________
Life can only be understood in reverse. But must be lived forward.
Psykomanius is offline  
Old 06-28-2007, 03:01 AM   #49
skitey

skitey's Avatar
Re: Swp updated.
Quote:
Originally Posted by Psykomanius View Post
But, ProAsm you can fix it. Right
You are a Code Guru.....
Hehe...
roooofl
skitey is offline  
Old 06-30-2007, 08:14 AM   #50
ProAsm

ProAsm's Avatar
Re: Swp updated.
Swp update Version 3.8.4

Just a few items we managed to achieve which should be helpfull.

1. SwpSetup
The SwpSetup utility has had 2 additions to it.
a) PlayCD
This will enable Swp to utilize the tracks on your CD.
b) Mouse Invert
This is so you can set it before joining the game and is often overlooked.

While we are on the SwpSetup, I have changed the 'defaults setting' to how the swp.cfg file is setup.
There is no real ideal setup as speaking to several people everyone has their own ideas so we have made a compromise.
Any inputs to this is welcome.
Supergoofy, I suggest you rename and keep your special SwpSetup

2. CD Music
CD Music is now enabled in Swp but you need to go about this with caution and you will need the above SwpSetup (or SwpStartup) to get this going.
Basically make sure you have the CD inserted before you start the game.
Also if you have selected the PlayCD tick box, and there is no CD in your drive, there will be no music at all, even the internal music will be disabled.
So if you want to hear the internal music as at present, make sure the PlayCD Tickbox is unchecked.

3. SwpStartup
This is basically a rather elaborate SwpSetup only with a hell of a lot more options.
If you have the Maps folder, it will also list the maps in it and play then if you like.
Let me know on this as it does have quite a lot of potential and being converted to C++ makes it a lot easier to code etc.

4. The $Bullet TV Viewscreen.
Until such stage that we can fix this as I've rattled my brain on it and will probably have to call on Kens help at some stage, I have made a 'hack' so you dont have to cheat anymore or switch to 8 BPP.
Basically if the map is called $bullet.map then the Red Controls will drive the Yellow car which has the required Silver key
Like I say, its a hack, but takes away that guilty feeling when you have to cheat

http://www.proasm.com/files/sw/Swp38_4.zip

http://www.proasm.com/files/sw/SwpStartup.zip
__________________
http://www.proasm.com
ProAsm is offline  
Old 06-30-2007, 09:14 AM   #51
supergoofy

supergoofy's Avatar
Re: Swp updated.
Many thanks ProAsm

I have found some bugs:

1. The new SwpSetup.exe disables "Auto Aiming" in Swp.cfg
If you run SwpSetup.exe, save and run Swp.exe you will notice that "Auto Aiming" is now disabled. But it was enabled before running SwpSetup.exe. Also it changes your statusbar to the full statusbar (the one that shows all stats).

2. Error in SwpStartup.exe: '1.0' is not a valid floating point value
If you run SwpSetup.exe, choose your sound card, save and then run SwpStartup.exe you get this error.

3. Also another strange thing: If you run SwpStartup.exe, save and then run SwpSetup.exe, the sound card goes back to MPU-401 (as SwpSetup.exe shows)

4. If you run If you run SwpSetup.exe, save and then run SwpStartup.exe the music and sound are unchecked. Also SwpStartup.exe disables "inverse mouse".

5. SwpSetup.exe seems more reliable.
Last edited by supergoofy; 06-30-2007 at 01:52 PM.
supergoofy is offline  
Old 06-30-2007, 12:46 PM   #52
Psykomanius

Psykomanius's Avatar
Re: Swp updated.
Quote:
Originally Posted by ProAsm View Post
4. The $Bullet TV Viewscreen.
Until such stage that we can fix this as I've rattled my brain on it and will probably have to call on Kens help at some stage, I have made a 'hack' so you dont have to cheat anymore or switch to 8 BPP.
Basically if the map is called $bullet.map then the Red Controls will drive the Yellow car which has the required Silver key
Like I say, its a hack, but takes away that guilty feeling when you have to cheat
YEES !!!
Nice fix
__________________
Life can only be understood in reverse. But must be lived forward.
Psykomanius is offline  
Old 06-30-2007, 12:59 PM   #53
Hendricks266

Hendricks266's Avatar
Re: Swp updated.
Is the CDDevice parameter used? Because I made a CD image of the SW disc and I have it in Virtual Drive (N:). The way that parameter is supposed to work is:

CDDevice:
1 - C:
2 - D:
3 - E:
4 - F:

24 - Z:

This way it would load much faster and be less noisy while playing SW for me.
Hendricks266 is offline  
Old 06-30-2007, 01:46 PM   #54
supergoofy

supergoofy's Avatar
Re: Swp updated.
If you have one hard disk C: and many CD/DVD devices e.g.

D: , E: , F: , G: , H: , I: , J: etc. etc.

and you put your Shadow Warrior CD in drive H:

then you should edit Swp.cfg with the following:
PlayCD = 1
CDDevice = 4

This means that:
D: is CDDevice = 0
E: is CDDevice = 1
F: is CDDevice = 2
G: is CDDevice = 3
H: is CDDevice = 4
I: is CDDevice = 5
J: is CDDevice = 6

Tested and works great.

ProAsm please add this info to your next pack, or implement it to SwpSetup.exe. Many thanks in advance.

[Edit]
CDDevice = 0 is considered your first CD/DVD device, no matter what letter has.

If you had 3 hard disks C: , D:, E: , and your first CD/DVD device is F: then it should be:
F: is CDDevice = 0
G: is CDDevice = 1
H: is CDDevice = 2
I: is CDDevice = 3
J: is CDDevice = 4
K: is CDDevice = 5

etc. etc.

I think that "CDDevice = " takes values from 0 - 9

Can I ask what the value "-1" does? It disables completely the CDDevice?
I also saw "PlayCD = -1", what does it do?
Last edited by supergoofy; 06-30-2007 at 02:05 PM.
supergoofy is offline  
Old 06-30-2007, 02:08 PM   #55
ProAsm

ProAsm's Avatar
Re: Swp updated.
Quote:
CDDevice:
1 - C:
2 - D:
3 - E:
4 - F:

24 - Z:
mmm I did not know that and will check it out.
How would the setup program do this for you.
I suppose I could use a DriveLetter Pulldown box or something.
Thanks on the headsup here
Currently the CDDevice just follows the PlayCD 0/0 1/1 etc.

Quote:
1. The new SwpSetup.exe disables "Auto Aiming" in Swp.cfg
Correct!
The reason is as follows.
In in normal setup, regardless of how you set the Mouse aiming, the first time you run SW you have to press the mouse toggle key - U in most cases else your mouse Y axis moves you forward and backwards.
For this to work correctly it needs to set the following:

[Controls]
MouseAiming = 0

[Options]
MouseAimingOn = 1

With that setting when you start SW the first time and play, the mouse is correct without having to toggle the key.
Previous versions did not have the correct setting of 'MouseAimingOn=1' in the [Options]

Quote:
2. Error in SwpStartup.exe: '1.0' is not a valid floating point value
Thanks for that.
At what point does it do this ?

Quote:
3. Also another strange thing: If you run SwpStartup.exe, save and then run SwpSetup.exe, the sound card goes back to MPU-401 (as SwpSetup.exe shows)
Yes sorry about that, its my fault as I knew there was something I still needed to do and this was it.
I'll have this corrected on the next release.

Quote:
4. If you run If you run SwpSetup.exe, save and then run SwpStartup.exe the music and sound are unchecked.
mmm I dont get that here, I run SwpSetup, save, exit, then run SwpStartup and both Music and Sound are checked ok.

Quote:
5. SwpSetup.exe seems more reliable.
Yes I agree but it should be as it only does the bare minimum requirements and will probably not be expanded much.

[edit]
mmm I see another post.
I'll get onto that drive letter thing asap and might mail you to test for me
The -1 is a C script thing which really p's me off.
Its supposed to be a 0 but it makes it a -1.
It should still work ok though.
__________________
http://www.proasm.com
Last edited by ProAsm; 06-30-2007 at 02:12 PM.
ProAsm is offline  
Old 06-30-2007, 02:28 PM   #56
supergoofy

supergoofy's Avatar
Re: Swp updated.
About the error in SwpStartup.exe: '1.0' is not a valid floating point value

If you run SwpSetup.exe, choose your sound card (e.g. "SB Audigy 2 Synth A" in my case), save and exit. Then run SwpStartup.exe you get this error at startup, and music and sound are unchecked.

After saving and re-run SwpStartup.exe, you get no error.
Last edited by supergoofy; 06-30-2007 at 02:38 PM.
supergoofy is offline  
Old 06-30-2007, 02:49 PM   #57
TerminX

TerminX's Avatar
Re: Swp updated.
The error re: floats is probably because you're using a language configuration in which decimal points aren't used to delimit floating point numbers. It sounds like SwpSetup.exe is using an international-friendly function to read in floats, but isn't using an international-friendly function to write them out.

Does it work if you open up the config created by SwpSetup.exe and change all of the decimal points in any floats you find to commas?
TerminX is offline  
Old 06-30-2007, 02:51 PM   #58
ProAsm

ProAsm's Avatar
Re: Swp updated.
Ahh yes ok, thats because of the MusicDevice error I still got.
Btw, the -1 in the case of the devices I see means they are disabled.

Sorry Tx, I did not see your post.
You are probably right and the reason is also possibly that I write them as a string but read them as a integer or float.
I use a string to get a space after the equal sign (just window dressing) and thats quite probably where its going wrong.
__________________
http://www.proasm.com
Last edited by ProAsm; 06-30-2007 at 02:56 PM.
ProAsm is offline  
Old 06-30-2007, 03:06 PM   #59
TerminX

TerminX's Avatar
Re: Swp updated.
Just read 'em in as strings and use a localized version of atof() or something.
TerminX is offline  
Old 06-30-2007, 03:18 PM   #60
ProAsm

ProAsm's Avatar
Re: Swp updated.
LOL I was just reading about that before I came here - will do that tnx

Question to anyone:
Seeing that the MusicDevice follows the Soundcard selection as described above, like from -1 (disabled) to possible 4 (in my case anyway), should the FXDevice not follow suite ?
I see in the original SwSetup and in SwpSetup its either -1 (disabled) or 0 which will always select the first option (in my book anyways).
__________________
http://www.proasm.com
ProAsm is offline  
Old 06-30-2007, 03:53 PM   #61
supergoofy

supergoofy's Avatar
Re: Swp updated.
FXDevice = 0 will always select your default sound card. You may have 2 sound cards, but the one that is set as default will be used

MusicDevice = 0, 1, 2, 3, 4. It surely does not select the sound card. But it selects the various modes that your sound card supports.

What I mean is that for my Audigy 2 there are 5 modes:
SB Audigy 2 Synth A
MPU-401
SB Audigy 2 Sw Synth
SB Audigy 2 Synth B
Microsoft GS Wavetable SW Synth

It is better to stick with FXDevice = 0 and MusicDevice = 0 as it will work for everyone and it will give you the best results, without problems.
supergoofy is offline  
Old 06-30-2007, 04:56 PM   #62
ProAsm

ProAsm's Avatar
Re: Swp updated.
Ok all the necessary changes have been done, but only to SwpStartup.exe as the other one is too complicated at this time of night
Hendricks266, it would be interesting to see if your virtual drive works with this.
It lists only cdrom/dvd drives but list them to Z, so just pick the appropriate one and it should work.
Supergoofy, I cannot get that floating point error here regardless of what I do and on the cfg file you sent me also, no errors at all.
Anyway, the new one has made several corrections in that department.
In the last release I also left the debugging routines intact and this time they are disabled so maybe that played a part as well.

http://www.proasm.com/files/sw/SwpStartup.zip
__________________
http://www.proasm.com
ProAsm is offline  
Old 06-30-2007, 06:49 PM   #63
TerminX

TerminX's Avatar
Re: Swp updated.
ProAsm, go into the regional and language options control panel in Windows and change your decimal symbol to a comma. His config file will probably fail then.
TerminX is offline  
Old 07-01-2007, 12:43 AM   #64
ProAsm

ProAsm's Avatar
Re: Swp updated.
TerminX, how did you figure that out.
Yes you are 100% correct, I went and changed that to a comma and sure enough:
'1.0' is not a floating point value.
What does this mean, is he wrong or am I wrong or better still why would anyone want their decimal point to be a comma anyway.
I'll see if I can fix this somehow but the problem is the exception is thrown before it comes back to you so you dont get a chance to correct it.
Anyway thanks on the headsup on this.... one is never too old to learn
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-01-2007, 01:13 AM   #65
TerminX

TerminX's Avatar
Re: Swp updated.
Quote:
Originally Posted by ProAsm View Post
TerminX, how did you figure that out.
Yes you are 100% correct, I went and changed that to a comma and sure enough:
'1.0' is not a floating point value.
What does this mean, is he wrong or am I wrong or better still why would anyone want their decimal point to be a comma anyway.
I'll see if I can fix this somehow but the problem is the exception is thrown before it comes back to you so you dont get a chance to correct it.
Anyway thanks on the headsup on this.... one is never too old to learn
Well, I made an educated guess based on knowing lots of things and happened to be right.

In some countries, commas are used where we use decimal points, so my first guess was that that was probably the cause. Apparently, some of the functions you're using are taking this localization into account (probably has something to do with you mentioning you were reading the values as floats...). You need to either write your cfg files out using Windows-specific functions which take these localizations into account or you need to change your reading of floats to something which ignores them.
TerminX is offline  
Old 07-01-2007, 01:47 AM   #66
supergoofy

supergoofy's Avatar
Re: Swp updated.
The selection of CDDevice in your new SwpStartup.exe will not work.
Read my post #54 , I gave your 2 examples.

If someone has one hard disk C: , like me, and many CD/DVD devices should do as I said in my post. I used my Shadow Warrior CD Image with Daemon Tools virtual CD/DVD drive H: , and I have set the CDDevice = 4 . This way it works.

You should found a way to distinguish hard disks from CD/DVD drives, so SwpStartup.exe will show only CD/DVD drives and consider the first CD/DVD to CDDevice = 0 (no matter what the drive letter is).
supergoofy is offline  
Old 07-01-2007, 02:50 AM   #67
skitey

skitey's Avatar
Re: Swp updated.
1st
Quote:
Originally Posted by ProAsm View Post
TerminX, how did you figure that out.
Yes you are 100% correct, I went and changed that to a comma and sure enough:
'1.0' is not a floating point value.
hehe, i can confirm this.
my windows got the "," as default => I'm using GERMAN Windows XP and in this language we use , insted of .

2nd
About CD-Music:
I got 6 HD-Drives (C, D, F, G, X, Z),
2 CD-Drives (E, H)
1 Virtual-DaemonTools-Drive (I)

using the swpsetup.exe and ticking "PlayCD"...nothing
editing the swp.cfg and changing "CDDevice = 1" to "CDDevice = 2"...yeah, the image is played, hearing CD-Music...
changing "CDDevice = 2" to "CDDevice = 0" plays midi btw

update
ok, running this new "swpstartup" and changing to the correct cd-drive got the same effect.
But this little proggy don't read my new swp.cfg correct...
changing to CD-Drive I: , save, starting swpstartup again shows the cd-drive E:

--little offtopic ---

is there a posibility to make only an image of the shadow warrior audio tracks, instead of the whole mixed-mode content???

------------------
Last edited by skitey; 07-01-2007 at 02:56 AM.
skitey is offline  
Old 07-01-2007, 03:11 AM   #68
supergoofy

supergoofy's Avatar
Re: Swp updated.
Quote:
Originally Posted by skitey View Post

--little offtopic ---

is there a posibility to make only an image of the shadow warrior audio tracks, instead of the whole mixed-mode content???

------------------
of course there is. use nero to create a mixed mode cd. track 1 is the data tack (leave it blank). track2 etc. etc. are the music tracks (use the same order as in your original CD). You should give to your new mixed mode cd the same volume label as your original CD, but I don't think that does matter. As the program will check track2 etc. etc. for audio tracks.

p.s.: Before you do the above you can rip the audio tracks with nero to wav files. Then you can drag&drop these wav files to your mixed mode cd as audio tracks.

Quote:
Originally Posted by skitey View Post
2nd
About CD-Music:
I got 6 HD-Drives (C, D, F, G, X, Z),
2 CD-Drives (E, H)
1 Virtual-DaemonTools-Drive (I)

using the swpsetup.exe and ticking "PlayCD"...nothing
editing the swp.cfg and changing "CDDevice = 1" to "CDDevice = 2"...yeah, the image is played, hearing CD-Music...
changing "CDDevice = 2" to "CDDevice = 0" plays midi btw

update
ok, running this new "swpstartup" and changing to the correct cd-drive got the same effect.
But this little proggy don't read my new swp.cfg correct...
changing to CD-Drive I: , save, starting swpstartup again shows the cd-drive E:
In your case it should be:
E: is CDDevice = 0
H: is CDDevice = 1
I: is CDDevice = 2

Having mounted your SW CD image to your virtual drive I: and setting CDDevice = 2 you will hear the music tracks from CD.
If you specify CDDevice = 0 and drive E: is empty then you will hear midi music, that is correct. If you insert your SW CD disk in drive E: you should hear the music tacks from CD.
Last edited by supergoofy; 07-01-2007 at 04:23 AM.
supergoofy is offline  
Old 07-01-2007, 03:53 AM   #69
ProAsm

ProAsm's Avatar
Re: Swp updated.
Wow lots to answer.
Firstly I want to say thanks to guys for the help and beta testing as without this testing I would never figure this lot out.
Ok skitey thanks on the comma used in German Xp as that explains a lot.
Yes if you go into the Input menu and play with the X and Y-Axis sliders you will get many of those errors.
Anyways I managed to fix them all now so you wont get them anymore.
TerminX what i do now is read it in as a string, then search for the ',' (comma) and replace it with a dot then convert it to a float
Quote:
You should found a way to distinguish hard disks from CD/DVD drives, so SwpStartup.exe will show only CD/DVD drives and consider the first CD/DVD to CDDevice = 0 (no matter what the drive letter is).
This is exactly what it should do as I have disabled all the following:
NoFloppy - NoFixed - NoNetwork - NoABDrives
On my system it only shows CD and DVD drives and the first one is drive 0 although its the F drive but the letter is insignificant.
But if you are reading it different then we need to find out why so it can be corrected.
Quote:
The selection of CDDevice in your new SwpStartup.exe will not work.
Yes I see that as well as the MusicDevice, and I dont know why as all the listboxes are treated the same, yet some work and some dont.
I'll have to scrutinize it more carefully and see why this is.
I'll fix this after the French GP
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-01-2007, 04:18 AM   #70
supergoofy

supergoofy's Avatar
Re: Swp updated.
Quote:
Originally Posted by ProAsm View Post

This is exactly what it should do as I have disabled all the following:
NoFloppy - NoFixed - NoNetwork - NoABDrives
On my system it only shows CD and DVD drives and the first one is drive 0 although its the F drive but the letter is insignificant.
But if you are reading it different then we need to find out why so it can be corrected.
Maybe because I have SATA RAID0 configuration.
Thus, it shows hard disk C: (2 x hard disks in RAID0).

Probably it will also show a SCSI hard disk, but I'm not sure.
Last edited by supergoofy; 07-01-2007 at 04:25 AM.
supergoofy is offline  
Old 07-01-2007, 05:37 AM   #71
ProAsm

ProAsm's Avatar
Re: Swp updated.
Please download this test file and tell me what combinations gives you the best results as far as your drives are concerned.

http://www.proasm.com/files/other/DriveTest.zip

Tnx
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-01-2007, 05:54 AM   #72
supergoofy

supergoofy's Avatar
Re: Swp updated.
Your DriveTest shows only my CD/DVD drives (D: though K: ) using NoFloppy - NoFixed - NoNetwork - NoABDrives. It also shows free (non registered) drive letters (from L: though Z: ), but that's ok.

If I use NoFloppy - NoFixed - NoNetwork - NoABDrives - NoRAMDrives - NoTapeDrives - NoFreeDrives , I see only my CD/DVD drives from D: through K: , nothing else. This is better I think.

But what about USB RAM sticks, USB hard disks? I don't have such devices installed in my system, to be able to test, but it's a good question: If someone has this kind of devices what will happen? Are the NoRAMDrives - NoTapeDrives options for this kind of devices?

For these reasons it is better to enable the options NoFloppy - NoFixed - NoNetwork - NoABDrives - NoRAMDrives - NoTapeDrives - NoFreeDrives , in the DriveTest tool. Thus it will only show the available CD/DVD devices.

But your latest SwpStartup.exe shows all drives: A: B: C: D: E: etc. etc. Why? Something wrong with the code implementation. Probably a minor bug that is hard to be found?
Last edited by supergoofy; 07-01-2007 at 09:28 AM.
supergoofy is offline  
Old 07-01-2007, 10:27 AM   #73
ProAsm

ProAsm's Avatar
Re: Swp updated.
Ok I tried a memory stick and it sees that as a Floppy Drive so I have to leave that enabled, but setting the NoABDrives removes the actual floppy A:
I would also leave the Free drives to Z as people with strange drives could work out the driver letter and use that, like in Hendricks266 case, the N drive or whatever it ends up being.

The reason you see all the drives in SwpStartup is the same reason you have the '1.0' float error, which is fixed now.
If you want to check, go into your control panel and under Regional, click on Custom and change the Decimal Symbol from a comma to a dot.
You will find a whole new world open up to you
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-01-2007, 01:53 PM   #74
ProAsm

ProAsm's Avatar
Re: Swp updated.
SwpStartup update.

Well lets hope most the serious stuff is now sorted.
Fixed the floating point errors.
Fixed the MusicDevice and CDDevice options.
Fixed the slider adjustments for more linear control.
Improved slider scaling.
Added menu
This menu consists of mainly default setting options.
Save Defaults.
Load Defaults.
Selecting this option will save the current settings to a SwpStartup.cfg file which will now become your default settings for future use.
It can be loaded or updated at any time.
Reload Cfg.
This is an option to reload the current Swp.cfg, saves you exiting if you think you made a mistake in the settings.
Resolutions.
Reduced the number of video resolutions to a starting at 640 x 480.
This caused several problems before and this was the quickest fix.

SwpStartup.cfg
Besides this housing the Default Setup it also has a small config section.
[Configs]
ShowTabPos=0
This is for internal use and basically remembers the last tab after pressing Play Swp.
HardDrives=0
If anyone for some reason needs all the hard drives to be shown in the CD list, set this to HardDrives=1

http://www.proasm.com/files/sw/SwpStartup.zip
__________________
http://www.proasm.com
ProAsm is offline  
Old 07-01-2007, 02:43 PM   #75
supergoofy

supergoofy's Avatar
Re: Swp updated.
It seems to work ok now. Many thanks.
supergoofy is offline  
Old 07-01-2007, 06:40 PM   #76
Psykomanius

Psykomanius's Avatar
Re: Swp updated.
You have done a good work on SW ProAsm
__________________
Life can only be understood in reverse. But must be lived forward.
Psykomanius is offline  
Old 07-01-2007, 07:44 PM   #77
Hendricks266

Hendricks266's Avatar
Re: Swp updated.
1. I can't get CD music to work. I initiate the Virtual Drive, and set SwpStartup.exe to N:. I save it and when I open Swp, no music plays. When I changed the VD letter to D:, I selected it in SwpStartup, and the configuration file has CDDevice at 0 and PlayCD at 0. Whenever CDDevice is 0, PlayCD also becomes zero when Swp runs.

2. The Voxel Sprites option is reversed, I think. When the box is checked, it is off in-game, and vice-versa.

3. A lot of options seem to be reset to the defaut whenever SwpStartup is opened. Among these is Resolution, HRP ZipLoader, CDDevice, and possibly others.
Hendricks266 is offline  
Old 07-02-2007, 12:45 AM   #78
supergoofy

supergoofy's Avatar
Re: Swp updated.
1. Voxel Sprites is reversed or not working at all. Confirmed.

2. PlayCD and CDDevice are working correctly for me. SwpStartup gives the correct CDDevice number.

3. There is a minor problem with 1280x1024 selection

Hendricks266 do your have USB memory stick, or USB card reader, or external hard disk? Maybe that's the problem.
That's why I made the post #72
supergoofy is offline  
Old 07-02-2007, 09:55 AM   #79
ProAsm

ProAsm's Avatar
Re: Swp updated.
Hendricks266 I think you have a point here.
Basically just checking here I see I still had my Xp switched to German so I could fix the float error etc and this has a big effect on the CDRom drive settings also.
I now switched it back to USA and to get my CD Music working my CDDevice MUST = 1.
PlayCD= 1
CDDevice= 1

If CDDevice= 0 then regardless of of PlayCD is (1 or ) the game sets it to 0 and I have no CD Music.
I switch back to German and it works.
So somehow we going to have to compromise here although as USA needs the fisrt CDRom to be drive 1 and Germany needs it to be drive 0
For instcance on my standard USA settings my CDRom reads as drive F but I need to set it to Drive G to get the CD Music to work ok.
What I could do is change Swp to accept that if CDDevice=0 then see it as CDDevice=1
I'll check the other default stuff also.
Hell TX, you sure started a landslide here hahaha...

[edit]
Another bug I found is the latest version somehow has the mouseinvert (Y-Invert) tied up with ReverseStereo and this also has to do with the comma.
Looks like its back to the drawing board.
__________________
http://www.proasm.com
Last edited by ProAsm; 07-02-2007 at 10:27 AM.
ProAsm is offline  
Old 07-02-2007, 11:13 AM   #80
skitey

skitey's Avatar
Re: Swp updated.
@ProAsm

found another bug (CD-Music)...

the Music don't loop! after the playtime of the track is over, there is no cd music at all -.-
Only if you get killed and respawn, the music is played from beginning....until the track is finished again XD

Recognized at Episode1 Level 2
skitey is offline  
 

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:46 AM.

Page generated in 0.22542906 seconds (100.00% PHP - 0% MySQL) with 17 queries

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

Website is 1987-2014 Apogee Software, Ltd.
Ideas and messages posted here become property of Apogee Software Ltd.