Forum Archive

Go Back   3D Realms Forums > Archives > Other Apogee/3D Realms Games > Prey
Blogs FAQ Members List Social Groups Calendar Mark Forums Read

Notices

 
 
Thread Tools
Old 09-06-2009, 06:05 AM   #1
Sang

Sang's Avatar
Prey in Vista 64-bit
It's not working for me.. It installs fine but when I try playing it, the screen flickers for a while and I get that typical idTech box thing that says this:


"glprogs/interactionNormBumpH.vfp
glprogs/interactionAll.vfp
glprogs/interactionAll.vfp
-------------------------------
using ARB_vertex_buffer_object memory
using ARB2 renderSystem
found DLL in pak file: C:\Program Files (x86)\Prey\base\game00.pk4/gamex86.dll
copy gamex86.dll to C:\Program Files (x86)\Prey\base\gamex86.dll
could not create destination file
********************
ERROR: DLL extraction to fs_savepath failed

********************
DLL extraction to fs_savepath failed

Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL"

I have opened the PK4 file and tried to extract the DLL file to the appropriate location by hand, but that didn't work either. Does this mean the game fails because the PK4 file is corrupt? How can that be?

edit:

Well after Googling around a bit more it seems that my game00.pk4 file is indeed corrupt somehow. I can assure you that I bought the game legally (see attachment below).

Any chance of anyone sending me their game00.PK4 file?
Attached Images
File Type: jpg Snapshot_20090906.jpg (32.8 KB, 30 views)
__________________
traB pu kcip
Last edited by Sang; 09-06-2009 at 06:13 AM.
Sang is offline  
Old 09-06-2009, 07:20 AM   #2
Sang

Sang's Avatar
Re: Prey in Vista 64-bit
Pulverdings gave me the solution to the problem; right-click the shortcut, select "Run as Admin". It worked for me!
__________________
traB pu kcip
Sang is offline  
Old 09-06-2009, 08:58 AM   #3
Rapture_Rising

Rapture_Rising's Avatar
Re: Prey in Vista 64-bit
Its stupid having to run stuff as administrator. If i didnt run Prey as an admin it wouldn't save my game (i finished half the game before i realised that and i had to start over again ).
__________________
Here we go folks... The rarest creature in nature... The Duketard. I will now approach him very quitely and... Jam my thumb in his butt hole. That should REALLY piss him off!.
Rapture_Rising is offline  
Old 09-06-2009, 11:15 AM   #4
Sang

Sang's Avatar
Re: Prey in Vista 64-bit
I find it odd how you need to still select "run as administrator" even if you're trying to run the game as you normally would with an administrator account..
__________________
traB pu kcip
Sang is offline  
Old 09-06-2009, 02:35 PM   #5
Telee

Telee's Avatar
Re: Prey in Vista 64-bit
That stache looks good on you
__________________
Smoker incapacitated Telee
Telee is offline  
Old 09-06-2009, 08:08 PM   #6
ZuljinRaynor

ZuljinRaynor's Avatar
Re: Prey in Vista 64-bit
If you have UAC off it should work fine. I've never had to use "Run as administrator."
__________________
My vision is augmented.
ZuljinRaynor is offline  
Old 09-07-2009, 09:18 AM   #7
Sang

Sang's Avatar
Re: Prey in Vista 64-bit
Quote:
Originally Posted by Telee View Post
That stache looks good on you
Oo la la, teeny weeny string bikini
__________________
traB pu kcip
Sang is offline  
Old 01-09-2010, 08:11 AM   #8
xmrb2003x
Re: Prey in Vista 64-bit
What about windows 7? xmrb2003x

---------- Post added at 08:11 AM ---------- Previous post was at 08:10 AM ----------

Quote:
Originally Posted by xmrb2003x View Post
What about windows 7? xmrb2003x
Actually what about windows 7 64-bit? I heard some games can be buggy, although it's better than vista was at release.
xmrb2003x is offline  
Old 01-10-2010, 01:05 PM   #9
Mr. Wonko
Re: Prey in Vista 64-bit
I can play the game flawlessly in Windows 7 64 bit. Well, I've disabled all the UAC-Stuff since it's getting on my nerves anyway, and I think that might help in Vista, too.
Mr. Wonko is offline  
Old 01-28-2010, 08:47 AM   #10
Sang

Sang's Avatar
Re: Prey in Vista 64-bit
The problem (at least, my problem with Vista) was that programs can't extract or copy files to folders within, for example, Program Files, unless you run them as admin. It's pretty stupid IMO. Hence why I tried to avoid using Program Files under Vista and instead either installed everything to the C:\ root or C:\Games\... Makes things messy but a lot more comfortable to use.

Don't know the deal is with Windows 7, everything in Program Files is working for me so far but haven't played games like Prey.
__________________
traB pu kcip
Sang is offline  
Old 02-01-2010, 08:18 PM   #11
rjcrossley
Re: Prey in Vista 64-bit
Hi I am RJ

Iím having simular problems with Win 7. As a lot of my pc games wonít even load

can any one help

Iím running AMD athlon 65 x2 dual core processor 6000 + 3.01 GHZ with 4 gig ram onboard geforce 250 meg video card.

With the pc game PREY I have tick every thing in the compatibility nothing seems to work

This comes up though

With the current video card / driver combination dos not support the necessary Feat



Prey 1.0.103 win-x86 Jun 10 2006 00:44:11
3013 MHz AMD CPU with MMX & 3DNow! & SSE & SSE2 & SSE3 & HTT & x64
3968 MB System Memory
128 MB Video Memory
Winsock Initialized
Found interface: {56D281DF-D182-40B9-8C41-4C881BFAA135} NVIDIA nForce Networking Controller - 10.0.0.1/255.255.255.0
Sys_InitNetworking: adding loopback interface
prey using MMX & SSE & SSE2 & SSE3 for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Loaded pk4 C:\Program Files (x86)\Prey\base\game00.pk4 with checksum 0xe0be2928
Loaded pk4 C:\Program Files (x86)\Prey\base\pak000.pk4 with checksum 0x7dc00ede
Loaded pk4 C:\Program Files (x86)\Prey\base\pak001.pk4 with checksum 0xd06647b1
Loaded pk4 C:\Program Files (x86)\Prey\base\pak002.pk4 with checksum 0x57dce443
Loaded pk4 C:\Program Files (x86)\Prey\base\pak003.pk4 with checksum 0x263006fe
Loaded pk4 C:\Program Files (x86)\Prey\base\pak004.pk4 with checksum 0xcc075380
Current search path:
C:\Program Files (x86)\Prey/base
C:\Program Files (x86)\Prey\base\pak004.pk4 (3739 files)
C:\Program Files (x86)\Prey\base\pak003.pk4 (4111 files)
C:\Program Files (x86)\Prey\base\pak002.pk4 (5337 files)
C:\Program Files (x86)\Prey\base\pak001.pk4 (6270 files)
C:\Program Files (x86)\Prey\base\pak000.pk4 (3318 files)
C:\Program Files (x86)\Prey\base\game00.pk4 (2 files)
game DLL: 0x0 in pak: 0x0
Addon pk4s:
file system initialized.
--------------------------------------
----- Initializing Decls -----
------------------------------
------- Initializing renderSystem --------
using ARB renderSystem
renderSystem initialized.
--------------------------------------
2647 strings read from strings/english001.lang
Couldn't open journal files
couldn't exec editor.cfg
execing default.cfg
couldn't exec preyconfig.cfg
couldn't exec autoexec.cfg
2647 strings read from strings/english001.lang
----- Initializing Sound System ------
sound system initialized.
--------------------------------------
----- R_InitOpenGL -----
Initializing OpenGL subsystem
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
Couldn't find proc address for: wglGetExtensionsStringARB
Couldn't find proc address for: wglSwapIntervalEXT
Couldn't find proc address for: wglGetPixelFormatAttribivARB
Couldn't find proc address for: wglGetPixelFormatAttribfvARB
Couldn't find proc address for: wglChoosePixelFormatARB
Couldn't find proc address for: wglCreatePbufferARB
Couldn't find proc address for: wglGetPbufferDCARB
Couldn't find proc address for: wglReleasePbufferDCARB
Couldn't find proc address for: wglDestroyPbufferARB
Couldn't find proc address for: wglQueryPbufferARB
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB
...calling CDS: ok
...created window @ 0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...PIXELFORMAT 7 selected
...creating GL context: succeeded
...making context current: succeeded
Couldn't find proc address for: wglGetExtensionsStringARB
Couldn't find proc address for: wglSwapIntervalEXT
Couldn't find proc address for: wglGetPixelFormatAttribivARB
Couldn't find proc address for: wglGetPixelFormatAttribfvARB
Couldn't find proc address for: wglChoosePixelFormatARB
Couldn't find proc address for: wglCreatePbufferARB
Couldn't find proc address for: wglGetPbufferDCARB
Couldn't find proc address for: wglReleasePbufferDCARB
Couldn't find proc address for: wglDestroyPbufferARB
Couldn't find proc address for: wglQueryPbufferARB
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
------------------------------------
...initializing OpenAL
...calling LoadLibrary( 'openal32.dll' ): failed
...initializing OpenAL
...calling LoadLibrary( 'openal32.dll' ): failed
sound: STEREO
X..GL_ARB_multitexture not found
X..GL_ARB_texture_env_combine not found
X..GL_ARB_texture_cube_map not found
X..GL_ARB_texture_env_dot3 not found
X..GL_ARB_texture_env_add not found
X..GL_ARB_texture_non_power_of_two not found
X..GL_ARB_texture_compression not found
X..GL_EXT_texture_filter_anisotropic not found
X..GL_EXT_texture_lod not found
X..GL_1.4_texture_lod_bias not found
X..GL_EXT_shared_texture_palette not found
X..GL_EXT_texture3D not found
X..GL_EXT_stencil_wrap not found
X..GL_NV_register_combiners not found
X..GL_EXT_stencil_two_side not found
X..GL_ATI_separate_stencil not found
X..GL_ATI_fragment_shader not found
X..GL_ATI_text_fragment_shader not found
X..GL_ARB_vertex_buffer_object not found
X..GL_ARB_vertex_program not found
X..GL_ARB_fragment_program not found
********************
ERROR: The current video card / driver combination does not support the necessary features.
********************
The current video card / driver combination does not support the necessary features.
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL
rjcrossley is offline  
Old 02-06-2010, 10:31 AM   #12
Sang

Sang's Avatar
Re: Prey in Vista 64-bit
Have you tried what I said in the post above yours? ie. either install Prey to something like C:\Games or anything other than Program Files or Program Files (x86) or run the Prey.exe as admin (right click and select the option)
__________________
traB pu kcip
Sang is offline  
Old 02-06-2010, 11:40 AM   #13
KO Gilligan

KO Gilligan's Avatar
Re: Prey in Vista 64-bit
on board solutions are always problematic with gaming

if you're in the US you can pick up a cheap video card that will play all but the most demanding games.

don't bother with a 9400 or a 4350... you'll want to get something with at least the 8600/9500 level of power on the toms heiarchy chart.

just as a rough idea, here is a bunch of middle of the road solutions going from fastest to slowest.

8800 GT 512MB, 8800 GTS 512MB, 9800 GT 4830
8800 GTS 640 MB, 9600 GT HD 2900 XT, 3870
8800 GS, 9600 GSO 3850 512MB, 4670
8800 GT 256MB, 8800 GTS 320MB, HD 2900 PRO, 3850 256MB, 4650
7950 GX2 X1950 XTX
7800 GTX 512, 7900 GTO, 7900 GTX X1900 XT, X1950 XT, X1900 XTX
7800 GTX, 7900 GT, 7950 GT X1800 XT, X1900 AIW, X1900 GT, X1950 PRO, HD 2900 GT
7800 GT, 7900 GS, 8600 GTS, 9500 GT (GDDR3) X1800 XL, X1950 GT, Mobility X1800 XT
6800 Ultra, 7600 GT, 7800 GS, 8600 GT (GDDR3), 9500 GT (DDR2) X800 XT (& PE), X850 XT (& PE), X1650 XT, X1800 GTO, Mobility X1900, HD 2600 XT, 3650 (DDR3), 3670
6800 GT, 6800 GS (PCIe), 8600 GT (DDR2) X800 XL, X800 GTO2/GTO16, HD 2600 PRO, 3650 (DDR2)


I see the 4650 and 9500 cards going for like $30-$40 bucks with a promotion rebate sometimes. But remember smaller bus width on cheap cards with the same chipset are a bit slower (64bit vs 128bit vs 256bit)

I have a couple machines with older cards that still game pretty well - I have a 2600pro and an old x1950 that still pull their weight at medium resolutions on newer games.

If I was to upgrade my stout old 3870 right now (which I need to badly) I'd probably be looking at the promotional $100-$150 cards - just can't afford any more really.

Some of those cards are power hogs - some are not... so plan your power supply needs accordingly

---------- Post added at 12:40 PM ---------- Previous post was at 12:31 PM ----------

Quote:
Originally Posted by xmrb2003x View Post
What about windows 7? xmrb2003x

---------- Post added at 08:11 AM ---------- Previous post was at 08:10 AM ----------



Actually what about windows 7 64-bit? I heard some games can be buggy, although it's better than vista was at release.
I play Prey on Win7 64 bit.... flawlessly
Q6600 - X38BT MBoard - ATI 3870
but there's no hope of making Bioshock sound work on my Intel Bonetrail on-board Intel HD sound chipset - not sure how it would do with a nice sound card.
Last edited by KO Gilligan; 02-06-2010 at 11:33 AM.
KO Gilligan is offline  
Old 07-21-2010, 06:01 AM   #14
BugsBunny
Re: Prey in Vista 64-bit
Just Installed Prey on Win 7 x64 last Friday and finished it completely without any hassles. "Run in admin mode" was not needed in Win 7 x64.
BugsBunny is offline  
 

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 11:19 PM.

Page generated in 0.21559906 seconds (100.00% PHP - 0% MySQL) with 17 queries

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

Website is ©1987-2014 Apogee Software, Ltd.
Ideas and messages posted here become property of Apogee Software Ltd.