Forum Archive

Go Back   3D Realms Forums > 3D Realms Topics > Other Apogee/3D Realms Games > Prey
Blogs FAQ Members List Social Groups Calendar Mark Forums Read

Notices

 
 
Thread Tools
Old 06-22-2006, 10:26 PM   #1
Brian Karis
Human Head Staff

Brian Karis's Avatar
ERROR: The current video card / driver combination does not support the necessary fea
If you have the message

"ERROR: The current video card / driver combination does not support the necessary features."

it means the game is looking for some basic opengl functions that should be there if its a supported card. It is not finding them and reporting the error. This is evident of just a general problem with the drivers on your computer.

Vista:
This is showing up with people trying to run it on vista with beta drivers that don't actually have correct opengl support. I believe the current ATI vista drivers fall in this camp. Vista beta is not supported.

Not Vista:
It seems thereís a good chunk that have this happen and arenít on vista. Most likely this is due to your drivers being in some sort of bad state. How this would happen I donít know. Try another opengl app such as doom 3 or quake 4. If you have problems with those you know there is a problem with opengl. My only current suggestion to correct that problem is to reinstall your video card drivers. Try installing the latest from the OEM site. I know a lot of you use drivers from other places but try the real ones to be sure. Past that I am not an expert in video cards or drivers so why they would not be working, I do not know.

All my replies to this problem will be in this thread. Hopefully we can focus this instead of there being random posts about it in other threads.
Brian Karis is offline  
Old 06-23-2006, 09:10 AM   #2
nizzem
Re: ERROR: The current video card / driver combination does not support the necessary
I've tried reinstalling my drivers and ive tried using archived nvidia drivers neither worked, does anyone know of any other way to maybe unintall and reinstall opengl? or any other fix for this problem?

I can play other games perfectly fine like: Counter strike source, half-life 2, DOD:Source, Hitman:Blood Money, Elder scrolls: Oblivion. Do any of those use opengl?

My system specs:

p4 3.0 ghz
2 gigs ram
BFGTech Nvidia Geforce 7800 GS OC - Driver Version: 8.4.2.1
Creative Soundblaster X-fi
nizzem is offline  
Old 06-23-2006, 10:06 AM   #3
SolidSnake961
Re: ERROR: The current video card / driver combination does not support the necessary fea
For anyone who has an ATI graphics card, go to the ati site for the latest driver/catalyst files instead of anywhere else. Either if it is mobility radeon or radeon for desktop.
SolidSnake961 is offline  
Old 06-23-2006, 11:19 AM   #4
neildittmar
Re: ERROR: The current video card / driver combination does not support the necessary fea
The error in question can also be indicative of the PC not having a video card that is supported by the games Doom 3 graphics engine. In other words, the video card being used does not contain the physical hardware necessary to run the game properly. In Doom 3, the minimum requirement was an ATI Radeon 8500 or GeForce 4MX series card. I'm sure the requirements for Prey are higher considering the additional graphical effects that the game uses.

That said, the first thing one should affirm when receiving this error is that the video card being used contains a chipset that is supported in the games minimum system requirements. These supported chipsets should be available in the ReadMe and on the game box upon release. Note that in most contemporary games, integrated video chipsets (such as Intel Extreme Graphics) are largely unsupported. While later integrated chipsets are capable of running the game, the performance will most likely be questionable even at the lowest of in-game resolutions and image qualities.

If the PC that is displaying the error at hand is running a video card with a supported video chipset, a mangled video driver could be the culprit. Over the years, I have devised a methodology for performing a clean video driver installation that could help clear up the problem. The steps for doing this can be found here.

Hope this helps.
neildittmar is offline  
Old 06-23-2006, 12:34 PM   #5
Buzzer

Buzzer's Avatar
Re: ERROR: The current video card / driver combination does not support the necessary
Quote:
Originally Posted by neildittmar
The error in question can also be indicative of the PC not having a video card that is supported by the games Doom 3 graphics engine. In other words, the video card being used does not contain the physical hardware necessary to run the game properly. In Doom 3, the minimum requirement was an ATI Radeon 8500 or GeForce 4MX series card. I'm sure the requirements for Prey are higher considering the additional graphical effects that the game uses.

That said, the first thing one should affirm when receiving this error is that the video card being used contains a chipset that is supported in the games minimum system requirements. These supported chipsets should be available in the ReadMe and on the game box upon release. Note that in most contemporary games, integrated video chipsets (such as Intel Extreme Graphics) are largely unsupported. While later integrated chipsets are capable of running the game, the performance will most likely be questionable even at the lowest of in-game resolutions and image qualities.

If the PC that is displaying the error at hand is running a video card with a supported video chipset, a mangled video driver could be the culprit. Over the years, I have devised a methodology for performing a clean video driver installation that could help clear up the problem. The steps for doing this can be found here.

Hope this helps.

I have a X1900XTX and had the same problem. ReÔnstalling the drivers worked for me. I wonder what made my OpenGL DLL's go bad tough, something in the Prey installer maybe? Kind of a weird coÔncidence that people with corrupt OpenGL drivers are popping up all of the sudden.

P.S. If you don't have Doom3 or Quake 4 you can confirm your problem by running the red car racing demo that's in one of the catalyst controll center options. I think you can see it in the anti aliasing setup menu. If an OpenGL driver warning message pops up it means you need to reÔnstall your video drivers.
Last edited by Buzzer; 06-23-2006 at 12:38 PM.
Buzzer is offline  
Old 06-23-2006, 12:51 PM   #6
Dopefish7590

Dopefish7590's Avatar
Re: ERROR: The current video card / driver combination does not support the necessary fea
Wow another forum asked the same question Link
Dopefish7590 is offline  
Old 06-23-2006, 02:35 PM   #7
nizzem
Re: ERROR: The current video card / driver combination does not support the necessary fea
ok so I installed Doom 3 to see if it had the same problem, and it did.
SO if my Opengl is corrupt how would I go about fixing it?
nizzem is offline  
Old 06-23-2006, 02:50 PM   #8
Brian Karis
Human Head Staff

Brian Karis's Avatar
Re: ERROR: The current video card / driver combination does not support the necessary fea
For people having problems cleaning drivers you can try this. I haven't tried it myself but I have heard it helps when there is problems.

Guide to cleaning video drivers:
http://forums.guru3d.com/showthread.php?t=67799
Brian Karis is offline  
Old 06-23-2006, 03:06 PM   #9
nizzem
Re: ERROR: The current video card / driver combination does not support the necessary
Ok I fixed my problem. Certain drivers for my motherboard were conflicting with my Video card drivers. so i unistalled the Asus Enhanced display Drivers and my Nvidia drivers, rebooted, reinstalled the nvidia drivers, reboot again. Finally prey launch. Kind of odd that those extra drivers didn't conflict with any other games I have on my pc. (Counter Strike: Source, Half-Life 2, Hitman Blood money, The Godfather, and Elder Scrolls Oblivion)

Thank you all for the help, not a real computer wiz if you couldnt tell. (What dumbass keeps extra drivers on his pc)
Special thnx to Brian Karis for all the help
nizzem is offline  
Old 06-23-2006, 07:05 PM   #10
TerminX

TerminX's Avatar
Re: ERROR: The current video card / driver combination does not support the necessary
Quote:
Originally Posted by Brian Karis
For people having problems cleaning drivers you can try this. I haven't tried it myself but I have heard it helps when there is problems.

Guide to cleaning video drivers:
http://forums.guru3d.com/showthread.php?t=67799
It should probably be explicitly mentioned that anyone tooling around with Driver Cleaner can pretty easily hose their system, as Driver Cleaner can easily remove things like the NVIDIA nForce chipset drivers, et cetera. As such, anyone using Driver Cleaner does so entirely at their own risk. You guys have been warned!

Quote:
Originally Posted by nizzem
Kind of odd that those extra drivers didn't conflict with any other games I have on my pc. (Counter Strike: Source, Half-Life 2, Hitman Blood money, The Godfather, and Elder Scrolls Oblivion)
Ah, all of the other games you listed there are Direct3D based, whereas Prey, Doom 3, Quake 4, et cetera use OpenGL.
TerminX is offline  
Old 06-23-2006, 10:12 PM   #11
nizzem
Re: ERROR: The current video card / driver combination does not support the necessary fea
Quote:
Originally Posted by TerminX
Quote:
Originally Posted by nizzem
Kind of odd that those extra drivers didn't conflict with any other games I have on my pc. (Counter Strike: Source, Half-Life 2, Hitman Blood money, The Godfather, and Elder Scrolls Oblivion)
Ah, all of the other games you listed there are Direct3D based, whereas Prey, Doom 3, Quake 4, et cetera use OpenGL.
still odd that the asus drivers only conflicted with opengl.
nizzem is offline  
Old 06-24-2006, 03:26 AM   #12
thehunter1320
Re: ERROR: The current video card / driver combination does not support the necessary fea
alright then, beat this one...

doom 3 works fine, quake 4 works fine, i get that nice sexual little red car in my catalyst control center, i've disabled my soundcard, re-installed drivers three times, tried beta drivers, re-installed mobo drivers, re-installed my OS, re-downloaded the demo, re-installed the demo, cried for an hour

any ideas?

PS: ah yes... specs? 9600 pro, 512 MB ram, Asus mobo (the model # escapes me... it uses a VIA chipset) AMD 2800+ Barton

PPS: i should be playing the demo on my Xbox 360 right now... :\

PPPS: contrary to popular belief... a post-script after a post-script is actually PPS not PSS... post-post-script is the correct term, not post-script-script
Last edited by thehunter1320; 06-24-2006 at 01:09 PM.
thehunter1320 is offline  
Old 06-24-2006, 01:09 PM   #13
thehunter1320
Re: ERROR: The current video card / driver combination does not support the necessary fea
i fixed my problem by rolling back my drivers to 6.4 catalyst
thehunter1320 is offline  
Old 06-24-2006, 11:49 PM   #14
IceColdDuke
Re: ERROR: The current video card / driver combination does not support the necessary fea
Just wondering is there anyway you guys could make that error message less vague (ie reporting what isn't detected with the error message?).
IceColdDuke is offline  
Old 06-25-2006, 12:34 AM   #15
TerminX

TerminX's Avatar
Re: ERROR: The current video card / driver combination does not support the necessary
Quote:
Originally Posted by IceColdDuke
Just wondering is there anyway you guys could make that error message less vague (ie reporting what isn't detected with the error message?).
The log reports the specific OpenGL extensions that weren't found.
TerminX is offline  
Old 06-25-2006, 09:45 AM   #16
tomservaux
Re: ERROR: The current video card / driver combination does not support the necessary fea
<rant>
I'm sorry but this thread is not the most helpful I've read. I have seen numerous people post exactly the same message which is, reinstall drivers. This cannot be a driver-only issue. I have reinstalled, cleaned, and installed old versions of drivers. Nothing has solved this problem. This should have been tested and solved by 3DRealms long before releasing this demo. I have yet to see a single person address what is actually causing this problem. IMHO blaming the drivers is lazy especially when people post that they have reinstalled and no one replies to them unless it is "Reinstall again".

If you are someone who understands the NVIDIA driver architecture who can help us to understand why uninstalling, cleaning, reinstalling drivers and rolling back do not solve this problem please post so we can actually resolve this. s it stands now I'm giving up on this game and going back to playing games that actually run without requiring me to understand how to hack my drivers.
</rant>
tomservaux is offline  
Old 06-25-2006, 09:49 AM   #17
tomservaux
Re: ERROR: The current video card / driver combination does not support the necessary fea
BTW, My system specs are:

AMD Athlon 64 Dual Core Processor 3800+ x2
3GB Dual Channel DDR RAM
Windows XP SP2
DirectX 9.0c
GeForce 7600
- PCI Express x16
- Bios 5.73.22.16.51
- 256MB RAM
- Forceware 91.31
tomservaux is offline  
Old 06-25-2006, 09:20 PM   #18
Karthik
Guest
Re: ERROR: The current video card / driver combination does not support the necessary
I remember installing VIA 4 in 1 drivers in order to make Max Payne run correctly. However a bug in it added a line in my Win.INI to disable all my OpenGL games. I found the fix here:
Activision
 
Old 06-26-2006, 12:03 AM   #19
Deadcode

Deadcode's Avatar
Re: ERROR: The current video card / driver combination does not support the necessary fea
i too am haveing this issue

i get the same message when i run the demo and the bad thing is even thoe i uninstalled the demo now all my OpenGL games dont run like Doom3 and Quake 4

i redownloaded my drivers as suggested for my Gfx Cards (91.31 WHQL) and uninstalled the ones i was useing and used Driver Cleaner Pro then reinstalled the drivers

then i started Quake 4 for a test and it started fine then when i shut down the game and tryed one more time just to make sure it ran "bingo" same prob the game will not run now

im Running WinXP64bit
my comp specs are

-AMD64 FX-55
-Asus A8N32-SLI Deluxe
-Enermax 600-Watt ATX SLI Ready Power Supply
-Corsair XMS 4GB (4 x 1GB) DDR SDRAM DDR 400 (PC3200) Dual Channel System Memory
-2x Asus Extreme Geforce 6800 Ultra SLIed Driver: 91.31 WHQL
-3x Western Digital Raptor HDs 1xModel WD360GD/2xModel WD740GD
-Windows XP Professional x64 Edition

any help on a fix to this prob would be nice i really dont want to have to Reformat just because of a bugged Demo
Deadcode is offline  
Old 06-26-2006, 09:42 AM   #20
maxlaiena
Re: ERROR: The current video card / driver combination does not support the necessary fea
I also have the same problem of most people here. The desktop becomes black, than gray and finally it returns to desktop without any error message. I have also installed Quake 4 so i tried to launch it but now it seems that also quake 4 doesn't start.

So i installed the earlier version of nvidia drivers 91.31, the newest version of directx (June 2006), the newest version of realtek ac97 drivers, but nothing.

The strange thing is that before installing the Pray demo, quake 4 was OK.

I don't know what to think...

By the way i have

-AMD64 3200 Venice
-DFI Lanparty Ultra d
-Enermax 500 Watt
-Vitesta 2x 512 MB DDR SDRAM DDR 400 (PC3200) Dual Channel System Memory
- Geforce 7800 GT 91.31 WHQL

-Windows XP Professional service pack 2
maxlaiena is offline  
Old 06-26-2006, 03:02 PM   #21
Nellyo_Mach
Guest
Re: ERROR: The current video card / driver combination does not support the necessary
look guys i had that irritating error but changing my drivers from forceware 91.31 to forceware 84.43 fixed the problem

here are my specs:

AMD Athlon 64 3500+ Claw Hammer
Gigabyte GA-K8NXP-9
2X 512MB Transcend
Asus EN6600 256MB
HD 160GB Seagate
DVD LG LightScribe GSA-4166B

hope this helps anyone, by the way i tried the sound card disabling trick and the reinstalling the game in another hard drive one two but both of them didn't work for me only this one
 
Old 06-26-2006, 03:06 PM   #22
Brian Karis
Human Head Staff

Brian Karis's Avatar
Re: ERROR: The current video card / driver combination does not support the necessary
Quote:
Originally Posted by tomservaux
<rant>
I'm sorry but this thread is not the most helpful I've read. I have seen numerous people post exactly the same message which is, reinstall drivers. This cannot be a driver-only issue. I have reinstalled, cleaned, and installed old versions of drivers. Nothing has solved this problem. This should have been tested and solved by 3DRealms long before releasing this demo. I have yet to see a single person address what is actually causing this problem. IMHO blaming the drivers is lazy especially when people post that they have reinstalled and no one replies to them unless it is "Reinstall again".
I have gone in to what the problem is and it is a driver issue. This is quite evident due to the fact that other games opengl do not work either.

The exact problem for those interested is the game checks for the opengl extensions that it needs to use to run the game. The ones needed to just launch are very minimal (multitexturing, etc). Things that any modern video card would have as well as anything that meets the min specs. The drivers report back that these extensions arenít supported. This must then be a problem with your configuration.

We are trying to help out people to make the game work on their systems. The more that can play the better. Technically this isnít our responsibility though. If your system canít run opengl itís not our problem. Weíve had more testing then you would believe. I think this has been quite successful in how little actual bugs reported we have that arenít system configuration related. Itíd be nice not to be criticized for handling things badly and being lazy for spending my time trying to help people with their computers to fix a problem that is not our fault. So if you want to move on and play other games go ahead but they wonít be opengl games because thatís what doesnít work. To the people that have been helpful and have put in a lot of time trying to run Prey, I thank you. The more info we have on this problem the easier hopefully it will be to fix.

At the moment Iíd donít know what would cause this situation. I suspect we wonít find this out. I also donít have a bulletproof fix for it. I have a feeling this isnít going to happen completely either. We have had so far different people fixing their problems in different ways. Driver reinstalls have fixed it. Solving a conflict between motherboard and video drivers have fixed it. I am guessing there will be different situations that will cause this and one solution wonít fix everyone. Hopefully in the end we will have enough ideas for everyone to get this fixed one way or another.
Brian Karis is offline  
Old 06-26-2006, 06:59 PM   #23
Deadcode

Deadcode's Avatar
Re: ERROR: The current video card / driver combination does not support the necessary fea
im at a lost here i posted my prob on Nvidias forum and most say that Prey Demo and all there OpenGL games run fine useing the 91.31 WHQL Driver

i just wish i had tested my Quake4 and Doom3 before i tried the Prey Demo useing the 91.31WHQL drivers
Deadcode is offline  
Old 06-26-2006, 09:47 PM   #24
Deadcode

Deadcode's Avatar
Re: ERROR: The current video card / driver combination does not support the necessary fea
sry for the back to back posts

ok i reinstalled driver 84.56 and all is fixed

so looks like it mite have been a driver issue with the 91.31 WHQL
Deadcode is offline  
Old 06-27-2006, 03:36 AM   #25
semelak1
Re: ERROR: The current video card / driver combination does not support the necessary fea
I have exactly the same problem, and couldn't find a fix for it yet. Reinstalling the driver didn't work. My video card is geforce 6600.
I will try installing 84.56 now, and see if that makes a difference.
semelak1 is offline  
Old 06-27-2006, 03:51 AM   #26
semelak1
Re: ERROR: The current video card / driver combination does not support the necessary fea
Unfortunately, reinstalling driver 84.56 didn't help.
semelak1 is offline  
Old 06-27-2006, 09:30 AM   #27
Nevyn
Re: ERROR: The current video card / driver combination does not support the necessary fea
I was having the same problem. I found a reasonable solution that may work for a lot of you.
I use an NVIDIA Geforce 7800 and recently installed the 91.31 drivers. I don't have Quake 4 or Doom 3 installed anymore so Prey demo was my only OpenGL game.
You may have noticed in your NVIDIA control panel under the section where all the quality/performance settings are, and only if you have the option checked; "show advanced features", is the variable "Extension limit" which can be set to 'on' or 'off'. Not knowing what this was at the time, I like many others, may set this to 'on', cos having things 'on' just seems to be better :P
Long story short. Turn it 'off' and all OpenGL games will work again.
Wanna know why? When it is 'on', it cuts short the string that describes all the extensions to OpenGL 1.1 that the driver/hardware supports, so the game thinks it doesn't have anything useful and bails. If NVIDIA had a profile set up for 'prey.exe' one of the application specific settings would most likely set "Extension limit" to 'off', saving you any hassle! Also, since this setting has been around for years, downgrading drivers won't change it, because it existed in earlier versions!

In summary: Turn (and double check!) "EXTENSION LIMIT" to 'OFF' and prey.exe might start working again. Let us know how this works for you!

*edit* Would any ATi users be able to tell us if a similar option exists in Catalyst drivers? As this may also explain ATi users having the same problem.
Last edited by Nevyn; 06-28-2006 at 12:02 AM.
Nevyn is offline  
Old 06-27-2006, 11:17 AM   #28
semelak1
Re: ERROR: The current video card / driver combination does not support the necessary fea
Quote:
Originally Posted by Nevyn
I was having the same problem. I found a reasonable solution that may work for a lot of you.
I use an NVIDIA Geforce 7800 and recently installed the 91.31 drivers. I don't have Quake 4 or Doom 3 installed anymore so Prey demo was my only OpenGL game.
You may have noticed in your NVIDIA control panel under the section where all the quality/performance settings are, and only if you have the option checked; "show advanced features", is the variable "Extension limit" which can be set to 'on' or 'off'. Not knowing what this was at the time, I like many others, may set this to 'on', cos having things 'on' just seems to be better :P
Long story short. Turn it 'off' and all OpenGL games will work again.
Wanna know why? When it is 'on', it cuts short the string that describes all the extensions to OpenGL 1.1 that the driver/hardware supports, so the game thinks it doesn't have anything useful and bails. If NVIDIA had a profile set up for 'prey.exe' one of the application specific settings would most likely set "Extension limit" to 'off', saving you any hassle! Also, since this setting has been around for years, downgrading drivers won't change it, because it existed in earlier versions!

In summary: Turn "EXTENSION LIMIT" to 'OFF' and prey.exe might start working again. Let us know how this works for you!
It is set "off" by default in my system.
semelak1 is offline  
Old 06-27-2006, 05:02 PM   #29
Deadcode

Deadcode's Avatar
Re: ERROR: The current video card / driver combination does not support the necessary fea
im going to try what Nevyn said and see if that is the prob and im redownloading the Prey Demo and the 91.31WHQL drivers

mybe the Driver is setting a new default

i dont mind sence i know i can go back to the older driver and all should be fixed
Deadcode is offline  
Old 06-27-2006, 07:03 PM   #30
Deadcode

Deadcode's Avatar
Re: ERROR: The current video card / driver combination does not support the necessary fea
sry again for the back to back posts

but i think Nevyn hit on the head from what im useing. i reinstalled the 91.31WHQL driver and made sure that EXTENSION LIMIT was set to OFF

and all works 100% and i have all other settings maxed or on

btw on a side note for u makers of this game way to go this demo rocks. evrytime i think i seen all the that Doom3 engine can do u guys just make it better man i thought Quake 4 was killer man Prey is my new Standard on that engine

gona try and Pre Order the Collectors Editon for PC asap
Deadcode is offline  
Old 06-28-2006, 02:19 AM   #31
dimausas
Re: ERROR: The current video card / driver combination does not support the necessary fea
The game is simply AWESOME!!!
Everything rocks: the smooth portals you can see thru, the gravity puzles, the wall walk, the spirit thing and the graphics engine.

when i first installed it, it worked perfectly apart from minor video glitches with black portals and such which was all fixed by disabling Catalist A.I.(maybe you can make it work in the final make or a patch).

I got thru the single play and tryed the Multyprey. Still no problem there.

But. the next day, when i wanted to show the demo to my friend would not launch with the above error! BIZARRE!

Uninstalled kipping settings and third party files. reinstalled. NO LUCK.
Uninstalled removing settings and third party files. reinstalled. WORKED!!!

Is the problem lays with the Multipray?

My config: ATI HIS X1800 XT 512MB with Catalist 6.5, 3GHz, 2GB RAM, Win XP SP2
dimausas is offline  
Old 06-28-2006, 06:51 AM   #32
semelak1
Re: ERROR: The current video card / driver combination does not support the necessary fea
Quote:
Originally Posted by Deadcode
sry again for the back to back posts

but i think Nevyn hit on the head from what im useing. i reinstalled the 91.31WHQL driver and made sure that EXTENSION LIMIT was set to OFF

and all works 100% and i have all other settings maxed or on

btw on a side note for u makers of this game way to go this demo rocks. evrytime i think i seen all the that Doom3 engine can do u guys just make it better man i thought Quake 4 was killer man Prey is my new Standard on that engine

gona try and Pre Order the Collectors Editon for PC asap
It doesn't work for me, I donnu why......... it's so depressing. I've had the demo on my desktop since the day it was released, and I was never able to play it.

Code:
Prey 0.2.95 win-x86 May 30 2006 21:14:05
2210 MHz AMD CPU with MMX & 3DNow! & SSE & SSE2 & x64
1024 MB System Memory
256 MB Video Memory
Winsock Initialized
Found interface: {1CD64D31-092C-44F5-BD8E-9C3D484DBBC0} NVIDIA nForce Networking Controller - Packet Scheduler Miniport - 192.168.1.2/255.255.255.0
Sys_InitNetworking: adding loopback interface
prey using MMX & SSE & SSE2 for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Loaded pk4 C:\Program Files\Prey Demo\base\demo00.pk4 with checksum 0x86294060
Current search path:
C:\Program Files\Prey Demo/base
C:\Program Files\Prey Demo\base\demo00.pk4 (11273 files)
game DLL: 0x0 in pak: 0x0
Addon pk4s:
file system initialized.
--------------------------------------

Running in restricted demo mode.

----- Initializing Decls -----
------------------------------
------- Initializing renderSystem --------
using ARB renderSystem
renderSystem initialized.
--------------------------------------
2647 strings read from strings/english001.lang
Couldn't open journal files
couldn't exec editor.cfg
execing default.cfg
couldn't exec preyconfig.cfg
couldn't exec autoexec.cfg
2647 strings read from strings/english001.lang
----- Initializing Sound System ------
sound system initialized.
--------------------------------------
----- R_InitOpenGL -----
Initializing OpenGL subsystem
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
Couldn't find proc address for: wglGetExtensionsStringARB
Couldn't find proc address for: wglSwapIntervalEXT
Couldn't find proc address for: wglGetPixelFormatAttribivARB
Couldn't find proc address for: wglGetPixelFormatAttribfvARB
Couldn't find proc address for: wglChoosePixelFormatARB
Couldn't find proc address for: wglCreatePbufferARB
Couldn't find proc address for: wglGetPbufferDCARB
Couldn't find proc address for: wglReleasePbufferDCARB
Couldn't find proc address for: wglDestroyPbufferARB
Couldn't find proc address for: wglQueryPbufferARB
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB
...calling CDS: ok
...created window @ 0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...PIXELFORMAT 7 selected
...creating GL context: succeeded
...making context current: succeeded
Couldn't find proc address for: wglGetExtensionsStringARB
Couldn't find proc address for: wglSwapIntervalEXT
Couldn't find proc address for: wglGetPixelFormatAttribivARB
Couldn't find proc address for: wglGetPixelFormatAttribfvARB
Couldn't find proc address for: wglChoosePixelFormatARB
Couldn't find proc address for: wglCreatePbufferARB
Couldn't find proc address for: wglGetPbufferDCARB
Couldn't find proc address for: wglReleasePbufferDCARB
Couldn't find proc address for: wglDestroyPbufferARB
Couldn't find proc address for: wglQueryPbufferARB
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
------------------------------------
...initializing OpenAL
...calling LoadLibrary( 'openal32.dll' ): succeeded
...checking for ALC_ENUMERATION_EXT: succeeded
...shutting down OpenAL
...unloading OpenAL DLL
...initializing OpenAL
...calling LoadLibrary( 'openal32.dll' ): succeeded
...creating AL device: succeeded
...creating AL context: succeeded
...making context current: succeeded
...shutting down OpenAL
...unloading OpenAL DLL
sound: STEREO
X..GL_ARB_multitexture not found
X..GL_ARB_texture_env_combine not found
X..GL_ARB_texture_cube_map not found
X..GL_ARB_texture_env_dot3 not found
X..GL_ARB_texture_env_add not found
X..GL_ARB_texture_non_power_of_two not found
X..GL_ARB_texture_compression not found
X..GL_EXT_texture_filter_anisotropic not found
X..GL_EXT_texture_lod not found
X..GL_1.4_texture_lod_bias not found
X..GL_EXT_shared_texture_palette not found
X..GL_EXT_texture3D not found
X..GL_EXT_stencil_wrap not found
X..GL_NV_register_combiners not found
X..GL_EXT_stencil_two_side not found
X..GL_ATI_separate_stencil not found
X..GL_ATI_fragment_shader not found
X..GL_ATI_text_fragment_shader not found
X..GL_ARB_vertex_buffer_object not found
X..GL_ARB_vertex_program not found
X..GL_ARB_fragment_program not found
********************
ERROR: The current video card / driver combination does not support the necessary features.
********************
The current video card / driver combination does not support the necessary features.
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL
And here is a snapshot from my video settings:
semelak1 is offline  
Old 06-28-2006, 07:32 AM   #33
maxlaiena
Re: ERROR: The current video card / driver combination does not support the necessary fea
Quote:
Originally Posted by Nevyn
I was having the same problem. I found a reasonable solution that may work for a lot of you.
I use an NVIDIA Geforce 7800 and recently installed the 91.31 drivers. I don't have Quake 4 or Doom 3 installed anymore so Prey demo was my only OpenGL game.
You may have noticed in your NVIDIA control panel under the section where all the quality/performance settings are, and only if you have the option checked; "show advanced features", is the variable "Extension limit" which can be set to 'on' or 'off'. Not knowing what this was at the time, I like many others, may set this to 'on', cos having things 'on' just seems to be better :P
Long story short. Turn it 'off' and all OpenGL games will work again.
Wanna know why? When it is 'on', it cuts short the string that describes all the extensions to OpenGL 1.1 that the driver/hardware supports, so the game thinks it doesn't have anything useful and bails. If NVIDIA had a profile set up for 'prey.exe' one of the application specific settings would most likely set "Extension limit" to 'off', saving you any hassle! Also, since this setting has been around for years, downgrading drivers won't change it, because it existed in earlier versions!

In summary: Turn (and double check!) "EXTENSION LIMIT" to 'OFF' and prey.exe might start working again. Let us know how this works for you!

*edit* Would any ATi users be able to tell us if a similar option exists in Catalyst drivers? As this may also explain ATi users having the same problem.
Are u sure that when u first installed 91.32 drivers the "EXTENSION LIMIT" was set to "ON" by default?
maxlaiena is offline  
Old 06-28-2006, 12:09 PM   #34
Deadcode

Deadcode's Avatar
Re: ERROR: The current video card / driver combination does not support the necessary fea
allso when useing the 91.31WHQL and useing the new control panal make sure that you set the EXTENSION LIMIT to OFF on the Global Setting and if you use SLI and use the Quake 4 or Doom3 Profile make sure that the EXTENSION LIMIT is OFF on that too
Deadcode is offline  
Old 06-28-2006, 01:45 PM   #35
semelak1
Re: ERROR: The current video card / driver combination does not support the necessary fea
Quote:
Originally Posted by maxlaiena
Are u sure that when u first installed 91.32 drivers the "EXTENSION LIMIT" was set to "ON" by default?
It is set to "OFF" by default in my system. I didn't make any changes and the game is still not working
semelak1 is offline  
Old 06-28-2006, 05:51 PM   #36
Deadcode

Deadcode's Avatar
Re: ERROR: The current video card / driver combination does not support the necessary fea
semelak1 are u useing the latest Drivers by Nvidia 91.31WHQL ?

cause from that 2nd pick i see on your desktop 82.21 and u are useing Clasic Control Panal
Deadcode is offline  
Old 06-28-2006, 08:13 PM   #37
Nevyn
Re: ERROR: The current video card / driver combination does not support the necessary
Quote:
Originally Posted by maxlaiena
Are u sure that when u first installed 91.32 drivers the "EXTENSION LIMIT" was set to "ON" by default?
I didn't say it was on by default. I said I turned it on.

semelak1 thanks for your input, but you've already established that the extension limit setting is not your problem, we really wish you luck but I can't think what might be causing your issue. Did you say if you have trouble running any other OpenGL applications? Apart from Doom3 engine games, what about an OpenGL graphics demo downloaded from NVidia?

And urgh, learn to only quote what is relevant to your reply please!
Nevyn is offline  
Old 06-29-2006, 03:06 AM   #38
semelak1
Re: ERROR: The current video card / driver combination does not support the necessary fea
Thanks everybody for trying to help.
I have tried installing/uninstalling different versions of nvidia drivers (including 84.21). The latest i tried was 91.31WHQL.
Since I don't own Quake4, I haven't really tried Quake4 or any other OpenGL game.

I have tried downloading several demos from this website:
http://nehe.gamedev.net/data/contest...asp?contest=06
and they all seem to work just fine. I am currently downloading a demo for Doom3. As soon as I try to run, I will report back with the result.
Last edited by semelak1; 06-29-2006 at 03:11 AM.
semelak1 is offline  
Old 06-29-2006, 03:35 AM   #39
maxlaiena
Re: ERROR: The current video card / driver combination does not support the necessary fea
Quote:
Originally Posted by semelak1
It is set to "OFF" by default in my system. I didn't make any changes and the game is still not working
The same for me. By default is set to off, but i can't modify the extention limit even when i flag the box. the bar that allows you to activate it is turned off.

...
maxlaiena is offline  
Old 06-29-2006, 03:44 AM   #40
semelak1
Re: ERROR: The current video card / driver combination does not support the necessary fea
Demo for Doom3 doesn't work
The contents of the error message window are the following:

Code:
DOOM 1.0.1280 win-x86 Sep 10 2004 16:46:16
2210 MHz AMD CPU with MMX & 3DNow! & SSE & SSE2
1024 MB System Memory
256 MB Video Memory
Winsock Initialized
Hostname: semelak1
IP: 192.168.1.5
doom using MMX & SSE & SSE2 for SIMD processing
enabled Flush-To-Zero mode
enabled Denormals-Are-Zero mode
------ Initializing File System ------
Loaded pk4 C:\PROGRA~1\DOOM3D~1\demo\demo00.pk4 with checksum 0x851c03dd
Current search path:
C:\PROGRA~1\DOOM3D~1/demo
C:\PROGRA~1\DOOM3D~1\demo\demo00.pk4 (12234 files)
game DLL: 0x0 in pak: 0x0
file system initialized.
--------------------------------------

Running in restricted demo mode.

----- Initializing Decls -----
------------------------------
Detected
 	2.21 GHz CPU
	1024 MB of System memory
	256 MB of Video memory on an optimal video architecture

This system qualifies for High quality!
------- Initializing renderSystem --------
using ARB renderSystem
renderSystem initialized.
--------------------------------------
5150 strings read from strings/english.lang
Couldn't open journal files
couldn't exec editor.cfg
execing default.cfg
couldn't exec DoomConfig.cfg
couldn't exec autoexec.cfg
5150 strings read from strings/english.lang
----- Initializing Sound System ------
sound system initialized.
--------------------------------------
----- R_InitOpenGL -----
Initializing OpenGL subsystem
...registered window class
...registered fake window class
...initializing QGL
...calling LoadLibrary( 'opengl32' ): succeeded
Couldn't find proc address for: wglGetExtensionsStringARB
Couldn't find proc address for: wglSwapIntervalEXT
Couldn't find proc address for: wglGetPixelFormatAttribivARB
Couldn't find proc address for: wglGetPixelFormatAttribfvARB
Couldn't find proc address for: wglChoosePixelFormatARB
Couldn't find proc address for: wglCreatePbufferARB
Couldn't find proc address for: wglGetPbufferDCARB
Couldn't find proc address for: wglReleasePbufferDCARB
Couldn't find proc address for: wglDestroyPbufferARB
Couldn't find proc address for: wglQueryPbufferARB
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB
...calling CDS: ok
...created window @ 0,0 (800x600)
Initializing OpenGL driver
...getting DC: succeeded
...PIXELFORMAT 7 selected
...creating GL context: succeeded
...making context current: succeeded
Couldn't find proc address for: wglGetExtensionsStringARB
Couldn't find proc address for: wglSwapIntervalEXT
Couldn't find proc address for: wglGetPixelFormatAttribivARB
Couldn't find proc address for: wglGetPixelFormatAttribfvARB
Couldn't find proc address for: wglChoosePixelFormatARB
Couldn't find proc address for: wglCreatePbufferARB
Couldn't find proc address for: wglGetPbufferDCARB
Couldn't find proc address for: wglReleasePbufferDCARB
Couldn't find proc address for: wglDestroyPbufferARB
Couldn't find proc address for: wglQueryPbufferARB
Couldn't find proc address for: wglBindTexImageARB
Couldn't find proc address for: wglReleaseTexImageARB
Couldn't find proc address for: wglSetPbufferAttribARB

------- Input Initialization -------
Initializing DirectInput...
mouse: DirectInput initialized.
keyboard: DirectInput initialized.
------------------------------------
sound: STEREO
X..GL_ARB_multitexture not found
X..GL_ARB_texture_env_combine not found
X..GL_ARB_texture_cube_map not found
X..GL_ARB_texture_env_dot3 not found
X..GL_ARB_texture_env_add not found
X..GL_ARB_texture_non_power_of_two not found
X..GL_ARB_texture_compression not found
X..GL_EXT_texture_filter_anisotropic not found
X..GL_EXT_texture_lod not found
X..GL_1.4_texture_lod_bias not found
X..GL_EXT_shared_texture_palette not found
X..GL_EXT_texture3D not found
X..GL_EXT_stencil_wrap not found
X..GL_NV_register_combiners not found
X..GL_EXT_stencil_two_side not found
X..GL_ATI_separate_stencil not found
X..GL_ATI_fragment_shader not found
X..GL_ARB_vertex_buffer_object not found
X..GL_ARB_vertex_program not found
X..GL_ARB_fragment_program not found
********************
ERROR: The current video card / driver combination does not support the necessary features.
********************
Error during initialization
Shutting down OpenGL subsystem
...wglMakeCurrent( NULL, NULL ): success
...deleting GL context: success
...releasing DC: success
...destroying window
...resetting display
...shutting down QGL
...unloading OpenGL DLL
semelak1 is offline  
 

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 06:14 PM.

Page generated in 0.40254092 seconds (100.00% PHP - 0% MySQL) with 18 queries

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

Website is ©1987-2014 Apogee Software, Ltd.
Ideas and messages posted here become property of Apogee Software Ltd.