Forum Archive

Go Back   3D Realms Forums > General Topics > Programming Forum > UnrealED Help
Blogs FAQ Members List Social Groups Calendar Mark Forums Read

Notices

 
 
Thread Tools
Old 10-14-2007, 04:06 PM   #1
C2S
Terrain editing: elevation resetting when painted on
Hi all,

I'm having the following problem with the terrain editor. Here's what often happens:

First I set up a simple flat heightmap in the terrains-tab, move to the next tab to define a few texture layers, and then proceed to painting the hills and valleys. I save often, and at some point I get the eventual crash. Accept, restart UnrealEd, reload map, go back to terrain editor. Terrain looks OK at this point. Now, when I continue to alter the elevation via painting, the area being painted on resets to some earlier state as I move the mouse. It's not the whole terrain that "resets", just the brush area. After doing the damage, the brush applies its desired effect, while simultaneously resetting more areas it hasn't yet reset. This prevents me from fine-tuning or extending any areas, because if the brush touches a previously completed area, it ruins it.

Since saving the map the normal way doesn't seem to save the terrain changes reliably, what should I try instead?

Thanks for your time. Other than this major annoyance, the tool is an excellent feature in the editor, so I would like to hear about a solution.
C2S is offline  
Old 10-15-2007, 12:26 PM   #2
Parkar

Parkar's Avatar
Re: Terrain editing: elevation resetting when painted on
Where do you have the hight maps? Sounds like you may not be putting them in the mylevel package(the package that gets saved inside the map file). If you have them in a external package you have to save that package manually.
Parkar is offline  
Old 10-15-2007, 02:39 PM   #3
C2S
Re: Terrain editing: elevation resetting when painted on
Yup, you nailed it, thanks.

After searching a bit, I found some posts recommending the Mylevel-package, so I've moved most textures in it as well. Now the terrain heightmap is stored with the normal save function, and all textures are embedded into the map file. I just didn't realize Mylevel is a special package, so instead, I was using a custom stratch-made package that better suited to my level name-wise... anyway, all fixed now and I'm using Mylevel instead.

Of course, the same thing applies to the texture layer alpha maps, and decoration density maps... it's good to know.
C2S is offline  
 

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:59 AM.

Page generated in 0.08516908 seconds (100.00% PHP - 0% MySQL) with 18 queries

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

Website is 1987-2014 Apogee Software, Ltd.
Ideas and messages posted here become property of Apogee Software Ltd.