Forum Archive

Go Back   3D Realms Forums > General Topics > Programming Forum
Blogs FAQ Members List Social Groups Calendar Mark Forums Read

Notices

 
 
Thread Tools
Old 01-08-2005, 11:16 PM   #1
boondocksaint
IE and code problems
Hi,
I need help and a couple of answers.
First of all, why is it that much of CSS doesn't work in IE?
If you go to my web site in Firefox and IE, you will see differences, such as background image in the iframe on the front page.

My main concern is javascript popup code which works in Firefox, but does not in IE. Click "matey" button, there is a section BIOS. If you click M, in FF, a window should open, while in IE, it does not.
I have this code in the HEAD section of the page:
Code:
 
<script language="JavaScript">

function michael(){
window.open("images/bios/m.png", "Michael Popov", "width=420px,height=520px,menubar=no,resizable=no,scrollbars=no,directories=no,,toolbar=no");}

</script>
The M button contains this code:
Code:
<a href="javascript: michael()"><img src="images/bios/m_thumb.png" border="0px"title="Michael Popov"></a>


What I'm asking is, is there a way to make my website function in both browsers?
boondocksaint is offline  
Old 01-09-2005, 10:22 AM   #2
the pineapplehead

the pineapplehead's Avatar
Re: IE and code problems
Yes, by coding to web standards.

You're missing a doctype, and a character set, and your code has numerous errors.

Run the page through validator.w3.org and go from there.

Sticking in a correct doctype will force IE into standards mode. IE second guesses your code, whereas FF displays it properly.
the pineapplehead is offline  
Old 01-09-2005, 11:59 AM   #3
boondocksaint
Re: IE and code problems
Okay, I put in doctype and character set.
I ran my pages through ther validator and got validated.
but it still doesn't work, and IE says that my problem is this line of
Code:
window.open("images/bios/m.png", "Michael Popov", "width=420px,height=520px,menubar=no,resizable=no,scrollbars=no,directories=no,toolbar=no");}
IE tells me that the error is Invalid Argument.
Also, is there a specific doctype I should use? HTML 4.01, XHTML 1.0?
boondocksaint is offline  
Old 01-09-2005, 11:36 PM   #4
boondocksaint
Re: IE and code problems
I fixed it! Woo Friggin Hoo!
boondocksaint is offline  
 

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 10:03 AM.

Page generated in 0.14421296 seconds (100.00% PHP - 0% MySQL) with 16 queries

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

Website is 1987-2014 Apogee Software, Ltd.
Ideas and messages posted here become property of Apogee Software Ltd.