Go Back   3D Realms Forums > General Gaming Topics > Max Payne

Reply
 
Thread Tools
Old 10-01-2004, 04:47 PM   #1
Riftgarde
Max Payne + Windows XP SP2 + DX9.0c
Max Payne no longer works with XP SP2 on this machine, nothing was changed except for the service pack, if sound is not disabled Max Payne crashes at "Loading".

Event Viewer:
The application, C:\Program Files\Games\Max Payne\MaxPayne.exe, generated an application error The error occurred on 10/01/2004 @ 14:45:17.390 The exception generated was c0000005 at address 003E2D33 (sndmfc!S_Listener__destruct)

It is at 1.05
The system's drivers are in order.
Windows update is current.
W2K compatibility has been tried.
No errors in DXdiag.
Riftgarde is offline   Reply With Quote
Old 10-01-2004, 07:12 PM   #2
Joonas
Re: Max Payne + Windows XP SP2 + DX9.0c
Hmm... Dunno about this one, Remedy confirmed that SP2 shouldn't affect Max Payne 2, but we don't know anything about the first game...
__________________
Deep Six's Content/Staff Director: http://www.3dap.com/maxpayne/
E-mail and MSN Messenger: joonasd6@gmail.com
Joonas is offline   Reply With Quote
Old 10-01-2004, 09:40 PM   #3
fmuder

fmuder's Avatar
Re: Max Payne + Windows XP SP2 + DX9.0c
I have SP2 and DX9.0c and it works fine.
fmuder is offline   Reply With Quote
Old 10-01-2004, 09:49 PM   #4
Riftgarde
Re: Max Payne + Windows XP SP2 + DX9.0c
I got Max Payne to work. It was the strangest thing. The sound card was set to 2.1

Apparently Max Payne crashes on startup with anything less than 4.1/5.1
Riftgarde is offline   Reply With Quote
Old 10-02-2004, 07:10 AM   #5
Joonas
Re: Max Payne + Windows XP SP2 + DX9.0c
Odd.
__________________
Deep Six's Content/Staff Director: http://www.3dap.com/maxpayne/
E-mail and MSN Messenger: joonasd6@gmail.com
Joonas is offline   Reply With Quote
Old 12-12-2004, 09:30 PM   #6
8IronBob

8IronBob's Avatar
Re: Max Payne + Windows XP SP2 + DX9.0c
Quote:
Riftgarde said:
I got Max Payne to work. It was the strangest thing. The sound card was set to 2.1

Apparently Max Payne crashes on startup with anything less than 4.1/5.1
Well, it crashed for me, I have a top of the line PC with all the bells and whistles, and it crashed right after the intro... I have an Intel P4 3.2 GHz w/ HT Tech, Win XP SP2, Intel HD Audio 5.1, ATI Radeon X300SE, 250 GB HDD, and 1GB Dual Channel RAM. You would think that Max Payne would fly low on a PC with this configuration, but it winds up crashing anyway. I sort of wonder if the Hyper-Threading technology would play a factor in this.
__________________
PC Specs: Antec 900 ATX Case, Gigabyte 790GX Mobo, AMD Phenom II x4 955, EVGA 2GB GTX 680, Corsair Vengeance 16GB DDR3-1600, 160GB X25-M SSD, 500GB+640GB WD Caviar Blacks, 8x LG Blu-ray burner, 3D Vision 2 Kit/3DTV Play, Toshiba TL32515U, Logitech Z-2300 Speakers, DAS Pro K/B, Logitech MX518 Mouse, Win 7 Pro x64, Wacom Bamboo Fun Tablet.
8IronBob is offline   Reply With Quote
Old 04-07-2005, 11:03 PM   #7
konik
Re: Max Payne + Windows XP SP2 + DX9.0c
Quote:
Riftgarde said:
I got Max Payne to work. It was the strangest thing. The sound card was set to 2.1

Apparently Max Payne crashes on startup with anything less than 4.1/5.1
Hi,could u please explain deeper what did u do?
Because I've got the same problem and I can play game only without sound,what is horrible!!!What means 2.1/4.1/5.1 ?
konik
konik is offline   Reply With Quote
Old 04-08-2005, 07:10 AM   #8
Joonas
Re: Max Payne + Windows XP SP2 + DX9.0c
Quote:
konik said:
What means 2.1/4.1/5.1 ?
konik
It tells you the amount of output sound channels (speakers). A 4.1 speaker set would mean four speakers around you and 1 low-frequency bass.
__________________
Deep Six's Content/Staff Director: http://www.3dap.com/maxpayne/
E-mail and MSN Messenger: joonasd6@gmail.com
Joonas is offline   Reply With Quote
Old 04-09-2005, 05:12 PM   #9
konik
Re: Max Payne + Windows XP SP2 + DX9.0c
Hi,thanks for answer! Can somebody tell me,how is possible to set audio card for 4.1 or 5.1? My card is:
Realtek AC' 97
I don't know why this game doesn't run,because some my friends had the same system and computer configuration and they can play it without problem!!!
konik is offline   Reply With Quote
Old 04-09-2005, 05:22 PM   #10
Joonas
Re: Max Payne + Windows XP SP2 + DX9.0c
Quote:
konik said:
Hi,thanks for answer! Can somebody tell me,how is possible to set audio card for 4.1 or 5.1? My card is:
Realtek AC' 97
I don't know why this game doesn't run,because some my friends had the same system and computer configuration and they can play it without problem!!!
I really doubt you can set it anywhere since that is a motherboard integrated sound chip. Try fiddling around with the game's sound settings.
__________________
Deep Six's Content/Staff Director: http://www.3dap.com/maxpayne/
E-mail and MSN Messenger: joonasd6@gmail.com
Joonas is offline   Reply With Quote
Old 04-13-2005, 08:52 AM   #11
konik
Re: Max Payne + Windows XP SP2 + DX9.0c
There is nothing to set,just sounds on/off.
Inside game is it useless,because if u set sounds off,u can't change it anyway.
konik is offline   Reply With Quote
Old 04-13-2005, 09:37 AM   #12
Joonas
Re: Max Payne + Windows XP SP2 + DX9.0c
Have you tried finding updated drivers for the onboard chipset?
__________________
Deep Six's Content/Staff Director: http://www.3dap.com/maxpayne/
E-mail and MSN Messenger: joonasd6@gmail.com
Joonas is offline   Reply With Quote
Old 04-13-2005, 10:31 PM   #13
konik
Re: Max Payne + Windows XP SP2 + DX9.0c
That"s no possible,because I have laptop and I can get drivers only from that company! Unfortunately,that company doesn't seem to care about customers and I can't find other drivers,cause it wouldn't work!!!!
konik is offline   Reply With Quote
Old 04-14-2005, 03:03 AM   #14
Mariamus
Senior Moderator

Mariamus's Avatar
Re: Max Payne + Windows XP SP2 + DX9.0c
Don't they have a website?
__________________
I would venture to warn against too great intimacy with artists as it is very seductive and a little dangerous. - Queen Victoria
Indeed, America's new slogan is slowly becoming "Land of the free.. unless it offends anyone!" - Hudson
Mariamus is offline   Reply With Quote
Old 06-06-2005, 04:47 PM   #15
Gah
Re: Max Payne + Windows XP SP2 + DX9.0c
Quote:
8IronBob said:
I sort of wonder if the Hyper-Threading technology would play a factor in this.
I can get the game to run fine with a P4 3.0G, so that's likely not it. However, hyperthreading did kill off my old copy of SystemShock2. There is a fix, though...and it works great now!

1. Launch game. Wait at splash screen.
2. Use CTRL+Shift+Esc to see Task Manager.
3. Click on Applications Tab.
3. Locate Game (MaxPayne.exe, or whatever).
4. Right Click and select Go To Process.
5. At process, right click and select Set Affinity...
6. Deselect "CPU 1". Click OK.
7. Return to game and go forward.

Might work for MP, might not. Worht a try for some of those hard to fix systems.

Also - I had tremendous trouble running MP with the RefreshFix application onboard. RefreshFix 0.9.9.7 certainly fixed the refresh rates, but killed off both Max Payne and Jedi Knight Outcast. I'll have to find another way to get the refresh rates fixed...
Gah is offline   Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:12 AM.

Page generated in 0.12045598 seconds (100.00% PHP - 0% MySQL) with 15 queries

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Website is 1987-2010 Apogee Software, Ltd.
Ideas and messages posted here become property of Apogee Software Ltd.