View Single Post
Old 10-24-2014, 02:25 PM   #1

eharris's Avatar
Issues with 3DR Website and Forum
I'm glad to see that 3DR is back and will be releasing games once again!

I've stumbled across a number of issues with the new website. I reported some of these issues to Joe, and he recommended that I get an account here and report them for you to investigate. (Which led me to another problem to report)

My primary browser is Firefox 33 in Windows 7 x64, but I've verified all but one of these problems in Internet Explorer 11 x64, too. For the one remaining problem, I've isolated its cause. Hopefully these will help further improve the new site.

First issue:

A number of your pages have a "Home" link on the top left. Those links point to nonexistent index.html files in that page's directory. here's an example from the "About" page, with red arrows pointing both to the link location and to the destination URL, as shown in Firefox (ditto in IE):

Second issue:

Your "Contact" page has a "Contact us" link that directs to #. Usually, I see "#" links when some kind of script call is being made to open a popup or something, but on this page, the link doesn't do anything in IE or Firefox. Fortunately, the page also has an email address posted on it, allowing users an easy workaround.

Third issue:

The system used to display content on the Team and Catalog pages didn't work for me in Firefox, but did in IE. I isolated the problem to one extension: "Search By Image (by Google) 1.1.2." Even though this extension shouldn't have any effect on page rendering, and I've never seen a problem associated with the extension before, 3DR's site conflicts with it somehow. The extension can be found here on Mozilla's Addons site. Since I'm not seeing this issue affecting multiple sites, I'll leave it to you to either work with Google on troubleshooting this further or to work around it.

Here's an example of what the Catalog page looks like with that extension enabled. Note that my cursor is hovering over Commander Keen's head, and there's actually a link there to the anthology pack, but it's invisible:

Fourth issue:

As I was making some of the screen shots above, I noticed that the same code that has issues with Google's Image Search extension also has problems with its dynamic resizing. I tried to make the screen shots relatively small, but large enough to show the problem, and I found that there's a pretty large range of viewport widths that cause the images to misbehave badly. They get very large and truncate. Here's an unexpectedly extreme close-up of the CEO's forehead (again, this problem exists in IE and FF, and also exists on the Catalog page):

Fifth issue:

When Joe suggested that I report these details on the forum, I tried to register for the forum. Unfortunately, through four separate attempts across both browsers, I was denied registration without any explanation beyond:

"Registration denied, this forum runs an active policy of not allowing spammers. Please contact us via the "Contact Us" page link if you believe this is in error" (This is when I discovered the "Contact us" problem)

I was able to see both CAPTCHA features (ReCAPTCHA and the text CAPTCHA containing either a very simple math problem or instructions to type text into the text box), and I only attempted registration when I was able to read the ReCAPTCHA text (or number, as ReCAPTCHA showed me text in Firefox and numbers in IE) with high confidence, so there's no way I entered the values wrong all four times. Either the site has my Verizon FIOS IP address on an overzealous spam blacklist, my email address somehow got into your system on a spam blacklist, or your forum is not allowing people to register. Hopefully vBulletin's logs are detailed enough to help troubleshoot. You should find the four registration attempts in the logs only a few minutes before Joe manually created my account for me.

I hope these reports are detailed enough to act upon. If you need any clarification or want me to take any additional troubleshooting steps, let me know.
Last edited by eharris; 10-24-2014 at 02:26 PM. Reason: quick typo fix
eharris is offline